summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-10 12:38:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-15 15:13:34 +0100
commita6fd9b8104e8d3cbfce0376811aeeef746ad6889 (patch)
tree6cdfdbadc4c2afd9e48bae7f4ea1b783718a8d7a
parente3152cf2e06e6ecbf4721d58b83f263bc2f46de2 (diff)
downloadopenembedded-core-contrib-a6fd9b8104e8d3cbfce0376811aeeef746ad6889.tar.gz
qt4: replace qt4-tools-native with qt4-native
Installs native versions of the Qt libraries in addition to the tools, allowing compilation of external native tools that require Qt libs. PROVIDES qt4-tools-native so it should be a drop-in replacement. Developed with reference to the corresponding qt4-native changes in OE. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--meta/recipes-qt/qt4/qt4-native.inc (renamed from meta/recipes-qt/qt4/qt4-tools-native.inc)20
-rw-r--r--meta/recipes-qt/qt4/qt4-native_4.7.3.bb (renamed from meta/recipes-qt/qt4/qt4-tools-native_4.7.3.bb)2
2 files changed, 15 insertions, 7 deletions
diff --git a/meta/recipes-qt/qt4/qt4-tools-native.inc b/meta/recipes-qt/qt4/qt4-native.inc
index c4a58ed849..3baea20a1c 100644
--- a/meta/recipes-qt/qt4/qt4-tools-native.inc
+++ b/meta/recipes-qt/qt4/qt4-native.inc
@@ -1,7 +1,8 @@
-DESCRIPTION = "Native tools for Qt/[X11|Mac|Embedded] version 4.x"
+DESCRIPTION = "Native version of Qt/[X11|Mac|Embedded]"
DEPENDS = "zlib-native dbus-native"
SECTION = "libs"
HOMEPAGE = "http://qt.nokia.com"
+PROVIDES = "qt4-tools-native"
LICENSE = "LGPLv2.1 | GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24 \
@@ -25,11 +26,11 @@ EXTRA_OECONF = "-prefix ${prefix} \
-no-libjpeg -no-libpng -no-libmng -no-libtiff \
-no-accessibility \
-no-cups \
- -no-exceptions \
-no-nas-sound \
-no-nis -no-openssl \
- -verbose -release -static \
+ -verbose -release \
-embedded -no-freetype -no-glib -no-iconv \
+ -exceptions -xmlpatterns \
-qt3support"
# yank default -e, otherwise we get the following error:
@@ -44,12 +45,15 @@ TOBUILD = "\
src/tools/moc \
src/corelib \
src/sql \
- src/dbus \
- src/qt3support \
src/xml \
+ src/network \
src/tools/uic \
src/tools/rcc \
- src/network \
+ src/xmlpatterns \
+ src/dbus \
+ src/gui \
+ src/testlib \
+ src/qt3support \
tools/linguist/lrelease \
tools/linguist/lupdate \
"
@@ -73,4 +77,8 @@ do_install() {
cp -f ${WORKDIR}/g++.conf ${WORKDIR}/linux.conf ${D}${datadir}/qt4/mkspecs/common/
install -m 0644 tools/porting/src/q3porting.xml ${D}${datadir}/qt4/
+
+ for i in ${TOBUILD}; do
+ cd ${S}/$i && oe_runmake install INSTALL_ROOT=${D}
+ done
}
diff --git a/meta/recipes-qt/qt4/qt4-tools-native_4.7.3.bb b/meta/recipes-qt/qt4/qt4-native_4.7.3.bb
index 8d292af3b5..5c84d4da61 100644
--- a/meta/recipes-qt/qt4/qt4-tools-native_4.7.3.bb
+++ b/meta/recipes-qt/qt4/qt4-native_4.7.3.bb
@@ -1,4 +1,4 @@
-require qt4-tools-native.inc
+require qt4-native.inc
PR = "${INC_PR}.1"