summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-01-26 12:42:16 +0000
committerSteve Sakoman <steve@sakoman.com>2023-02-10 09:01:29 -1000
commit9a110453f6b4b2c2d86af4ae20860037796a284d (patch)
treed6aeb37dd4b4a81e8949f67d7f930b4d17b7751e
parent986af8c9ae9d2cab0bc0376757f40b096448ae2a (diff)
downloadopenembedded-core-contrib-9a110453f6b4b2c2d86af4ae20860037796a284d.tar.gz
buildtools-tarball: set pkg-config search path
The buildtools-tarball includes a native sysroot with .pc files, and in the case of buildtools-extended-tarball a pkg-config binary too. If we're using the host pkg-config then it doesn't know to search in the native sysroot. If we're using our pkg-config then it searches in the build-time prefix and not the actual SDK installation location. Neither of these are correct, so set PKG_CONFIG_LIBDIR to search: - The native sysroot - The host pkg-config's default search path, if present - Falling back to /usr/lib/pkgconfig, if not In an ideal world this would be handled by the generic toolchain script, but that is slightly more involved. [ YOCTO #15007 ] Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 8f768a3f4c7ff477e994d60800e5a1b83891615a) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index de399173ba..34f7773398 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -75,6 +75,9 @@ create_sdk_files:append () {
echo 'export REQUESTS_CA_BUNDLE="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
echo 'export CURL_CA_BUNDLE="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
fi
+ echo 'HOST_PKG_PATH=$(command -p pkg-config --variable=pc_path pkg-config 2>/dev/null)' >>$script
+ echo 'export PKG_CONFIG_LIBDIR=${SDKPATHNATIVE}/${libdir}/pkgconfig:${SDKPATHNATIVE}/${datadir}/pkgconfig:${HOST_PKG_PATH:-/usr/lib/pkgconfig:/usr/share/pkgconfig}' >>$script
+ echo 'unset HOST_PKG_PATH'
toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}