summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-02-07 15:16:21 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-02-07 15:16:21 +0000
commit890f796ef7944dcba32dcc25d1e11e73ccf7f1cc (patch)
tree212b9ba8ec4abbd1f3dc76b26370b37eb926aa6d
parent6a402ce57849a03bc1cf219666a3eccec64ce39e (diff)
downloadopenembedded-core-contrib-890f796ef7944dcba32dcc25d1e11e73ccf7f1cc.tar.gz
coreutils: added 5.3.0 from OE .dev
- 5.3.0 is patched to be buildable with glibc 2.5 git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1262 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/coreutils/coreutils-native_5.3.0.bb7
-rw-r--r--meta/packages/coreutils/coreutils.inc7
-rw-r--r--meta/packages/coreutils/coreutils_5.1.3.bb19
-rw-r--r--meta/packages/coreutils/coreutils_5.3.0.bb82
4 files changed, 103 insertions, 12 deletions
diff --git a/meta/packages/coreutils/coreutils-native_5.3.0.bb b/meta/packages/coreutils/coreutils-native_5.3.0.bb
new file mode 100644
index 0000000000..ee90981895
--- /dev/null
+++ b/meta/packages/coreutils/coreutils-native_5.3.0.bb
@@ -0,0 +1,7 @@
+SECTION = "base"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/coreutils-${PV}"
+S = "${WORKDIR}/coreutils-${PV}"
+
+require coreutils_${PV}.bb
+inherit native
diff --git a/meta/packages/coreutils/coreutils.inc b/meta/packages/coreutils/coreutils.inc
new file mode 100644
index 0000000000..481c32bb3d
--- /dev/null
+++ b/meta/packages/coreutils/coreutils.inc
@@ -0,0 +1,7 @@
+DESCRIPTION = "A collection of core GNU utilities."
+LICENSE = "GPL"
+SECTION = "base"
+RREPLACES = "textutils shellutils fileutils"
+RPROVIDES = "textutils shellutils fileutils"
+
+inherit autotools
diff --git a/meta/packages/coreutils/coreutils_5.1.3.bb b/meta/packages/coreutils/coreutils_5.1.3.bb
index 2f7476c2dd..da9b214af5 100644
--- a/meta/packages/coreutils/coreutils_5.1.3.bb
+++ b/meta/packages/coreutils/coreutils_5.1.3.bb
@@ -1,8 +1,5 @@
-LICENSE = "GPL"
-SECTION = "base"
-DESCRIPTION = "A collection of core GNU utilities."
-RREPLACES = "textutils shellutils fileutils"
-RPROVIDES = "textutils shellutils fileutils"
+require coreutils.inc
+
PR = "r8"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
@@ -10,8 +7,6 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://man.patch;patch=1 \
file://rename-eaccess.patch;patch=1"
-inherit autotools
-
# [ gets a special treatment and is not included in this
bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
env expand expr factor fmt fold groups head hostid id install \
@@ -31,10 +26,10 @@ sbindir_progs= "chroot"
do_install () {
autotools_do_install
-
+
# Renaming the utilities that should go in /usr/bin
for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
-
+
# Renaming and moving the utilities that should go in /bin (FHS)
install -d ${D}${base_bindir}
for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
@@ -50,7 +45,7 @@ do_install () {
# hostname and uptime separated. busybox's versions are preferred
mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
-
+
}
pkg_postinst_${PN} () {
@@ -59,11 +54,11 @@ pkg_postinst_${PN} () {
# The utilities in /bin
for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
-
+
# The utilities in /usr/sbin
for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
- # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
+ # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
diff --git a/meta/packages/coreutils/coreutils_5.3.0.bb b/meta/packages/coreutils/coreutils_5.3.0.bb
new file mode 100644
index 0000000000..61d25543ab
--- /dev/null
+++ b/meta/packages/coreutils/coreutils_5.3.0.bb
@@ -0,0 +1,82 @@
+require coreutils.inc
+
+PR = "r1"
+
+SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
+ file://install-cross.patch;patch=1;pnum=0 \
+ file://man.patch;patch=1 \
+ file://rename-tee-for-glibc2.5.patch;patch=1 \
+ file://uptime-pow-lib.patch;patch=1"
+
+# [ gets a special treatment and is not included in this
+bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+ env expand expr factor fmt fold groups head hostid id install \
+ join link logname md5sum mkfifo nice nl nohup od paste pathchk \
+ pinky pr printenv printf ptx readlink seq sha1sum shred sort \
+ split stat sum tac tail tee test tr tsort tty unexpand uniq \
+ unlink users vdir wc who whoami yes \
+ "
+
+# hostname gets a special treatment and is not included in this
+base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
+ ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
+ true uname \
+ "
+
+sbindir_progs= "chroot"
+
+do_install () {
+ autotools_do_install
+
+ # Renaming the utilities that should go in /usr/bin
+ for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
+
+ # Renaming and moving the utilities that should go in /bin (FHS)
+ install -d ${D}${base_bindir}
+ for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
+
+ # Renaming and moving the utilities that should go in /usr/sbin (FHS)
+ install -d ${D}${sbindir}
+ for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
+
+ # [ requires special handling because [.coreutils will cause the sed stuff
+ # in update-alternatives to fail, therefore use lbracket - the name used
+ # for the actual source file.
+ mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
+ # hostname and uptime separated. busybox's versions are preferred
+ mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
+ mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
+
+}
+
+pkg_postinst_${PN} () {
+ # The utilities in /usr/bin
+ for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
+
+ # The utilities in /bin
+ for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
+
+ # The utilities in /usr/sbin
+ for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
+
+ # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
+ update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
+ update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
+ update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
+}
+
+pkg_prerm_${PN} () {
+ # The utilities in /usr/bin
+ for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The utilities in /bin
+ for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The utilities in /usr/sbin
+ for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
+
+ # The special cases
+ update-alternatives --remove hostname hostname.${PN}
+ update-alternatives --remove uptime uptime.${PN}
+ update-alternatives --remove '[' 'lbracket.${PN}'
+}