summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-12-07 11:52:06 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-09 10:33:21 +0000
commit73174b29d414ab0b5921f4fcdf5aebb988f0daf5 (patch)
treee43eba98cc757ef94fb4a24538df716bb6f1c891
parent613b131b19627961579d50af013648a4b0851dc6 (diff)
downloadopenembedded-core-contrib-73174b29d414ab0b5921f4fcdf5aebb988f0daf5.tar.gz
linux-yocto-dev: use versioned branch as default
The -dev kernel used to only have standard/* branches, which were managed similarly to linux-next. Which means, they are for testing integration of patches, and are rebased as needed (typically on version changes). We now do some leading edge BSP development on the -dev kernel, so the standard/* branches are not deleted, but are instead archived with a version prefix v<kernel version>/standard/* The branch renaming causes problems for maintained releases (they'll jump forward to newer kernels), and for anything that wants to specify a particular commit (-dev is AUTOREV by design). There's no reason why the branches can't start versioned at this point, and that solves both problems. So we switch our default branch to v5.16/standard/base now, and it will be updated with each new version (we bump the version anyway). Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index 6b6ea9a7e8..80f62a0412 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -16,7 +16,7 @@ inherit pkgconfig
# provide this .inc to set specific revisions
include recipes-kernel/linux/linux-yocto-dev-revisions.inc
-KBRANCH = "standard/base"
+KBRANCH ?= "v5.16/standard/base"
KMETA = "kernel-meta"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;branch=${KBRANCH};name=machine \