summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-05-15 10:44:32 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-21 12:07:18 +0100
commit5a8a116b270d26ce50429aa32f2883a9d2fd1206 (patch)
treed16dfbdc85d4641db2a524a8a0e06381ad41b9b9
parentf2f3f965d6d5fc19b357891e8c55473782124662 (diff)
downloadopenembedded-core-contrib-5a8a116b270d26ce50429aa32f2883a9d2fd1206.tar.gz
systemd: fix build against 6.9 libc-headers
When building against the 6.9 linux-libc-headrs the following build issue was hit: | Program check-filesystems.sh found: YES (build/tmp/work/cortexa57-poky-linux/systemd/255.4/git/src/basic/check-filesystems.sh) | | ../git/src/basic/meson.build:238:8: ERROR: Problem encountered: Unknown filesystems defined in kernel headers: | | Filesystem found in kernel header but not in filesystems-gperf.gperf: PID_FS_MAGIC Upstream already has this fixed, so we backport the commit. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd/0001-basic-add-PIDFS-magic-31709.patch53
-rw-r--r--meta/recipes-core/systemd/systemd_255.4.bb1
2 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0001-basic-add-PIDFS-magic-31709.patch b/meta/recipes-core/systemd/systemd/0001-basic-add-PIDFS-magic-31709.patch
new file mode 100644
index 0000000000..dd4be5ed2a
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-basic-add-PIDFS-magic-31709.patch
@@ -0,0 +1,53 @@
+From ed01b92e1c92871bbd92711f280e2b2d15753f0e Mon Sep 17 00:00:00 2001
+From: cpackham-atlnz <85916201+cpackham-atlnz@users.noreply.github.com>
+Date: Tue, 12 Mar 2024 00:55:36 +1300
+Subject: [PATCH] basic: add PIDFS magic (#31709)
+
+Kernel commit cb12fd8e0dabb9a1c8aef55a6a41e2c255fcdf4b added pidfs.
+Update filesystems-gperf.gperf and missing_magic.h accordingly.
+
+This fixes the following error building against a bleeding edge kernel.
+```
+../src/basic/meson.build:234:8: ERROR: Problem encountered: Unknown filesystems defined in kernel headers:
+
+Filesystem found in kernel header but not in filesystems-gperf.gperf: PID_FS_MAGIC
+```
+
+Upstream-Status: Backport [commit ed01b92e1c92871bbd92711f280e2b2d15753f0e]
+
+---
+ src/basic/filesystems-gperf.gperf | 1 +
+ src/basic/missing_magic.h | 5 +++++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/src/basic/filesystems-gperf.gperf b/src/basic/filesystems-gperf.gperf
+index e8c5357f91..1cd66b5a5f 100644
+--- a/src/basic/filesystems-gperf.gperf
++++ b/src/basic/filesystems-gperf.gperf
+@@ -91,6 +91,7 @@ ocfs2, {OCFS2_SUPER_MAGIC}
+ openpromfs, {OPENPROM_SUPER_MAGIC}
+ orangefs, {ORANGEFS_DEVREQ_MAGIC}
+ overlay, {OVERLAYFS_SUPER_MAGIC}
++pidfs, {PID_FS_MAGIC}
+ pipefs, {PIPEFS_MAGIC}
+ ppc-cmm, {PPC_CMM_MAGIC}
+ proc, {PROC_SUPER_MAGIC}
+diff --git a/src/basic/missing_magic.h b/src/basic/missing_magic.h
+index 27a33adecb..82d71c8ad1 100644
+--- a/src/basic/missing_magic.h
++++ b/src/basic/missing_magic.h
+@@ -128,6 +128,11 @@
+ #define DEVMEM_MAGIC 0x454d444d
+ #endif
+
++/* cb12fd8e0dabb9a1c8aef55a6a41e2c255fcdf4b (6.8) */
++#ifndef PID_FS_MAGIC
++#define PID_FS_MAGIC 0x50494446
++#endif
++
+ /* Not in mainline but included in Ubuntu */
+ #ifndef SHIFTFS_MAGIC
+ #define SHIFTFS_MAGIC 0x6a656a62
+--
+2.39.2
+
diff --git a/meta/recipes-core/systemd/systemd_255.4.bb b/meta/recipes-core/systemd/systemd_255.4.bb
index 62842d43c8..08af221a93 100644
--- a/meta/recipes-core/systemd/systemd_255.4.bb
+++ b/meta/recipes-core/systemd/systemd_255.4.bb
@@ -28,6 +28,7 @@ SRC_URI += " \
file://systemd-pager.sh \
file://0002-binfmt-Don-t-install-dependency-links-at-install-tim.patch \
file://0008-implment-systemd-sysv-install-for-OE.patch \
+ file://0001-basic-add-PIDFS-magic-31709.patch \
"
# patches needed by musl