summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Villemoes <rasmus.villemoes@prevas.dk>2024-04-23 11:57:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-05-21 12:07:32 +0100
commit572f511f7ff02fb559ac42d2d5dbd09fec478d97 (patch)
treee388ed28c6310c6bfe38134eeca1693000b89e35
parent4f73ddd6c276dcd579d2113db1974d446dbf7751 (diff)
downloadopenembedded-core-contrib-572f511f7ff02fb559ac42d2d5dbd09fec478d97.tar.gz
git: set --with-gitconfig=/etc/gitconfig for -native builds
Commit 6c2ae2346db0 (kern-tools: depend on git-replacement-native) broke our kernel builds. For saving space and time, we have a DL_DIR shared between multiple users/buildbots, not all of which run with the same uid (and with appropriate sticky bits set so that files downloaded by one user become owned by a common group and are readable by others). This works fine also for git sources because the docker images we use all have a /etc/gitconfig with [safe] directory = * But with the mentioned commit, the host's git is no longer used for do_unpack (nor for do_fetch if re-building and sysroot has already been populated by a previous build), causing spurious "fatal: detected dubious ownership..." failures. Currently, the path where the git-native binary searches for system gitconfig is the sysroot from it was built, which obviously doesn't contain a /etc/gitconfig. As for the nativesdk variant, respect the host's /etc/gitconfig if present. Signed-off-by: Rasmus Villemoes <rasmus.villemoes@prevas.dk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/git/git_2.44.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/git/git_2.44.0.bb b/meta/recipes-devtools/git/git_2.44.0.bb
index 90e555eba7..78b00dd19f 100644
--- a/meta/recipes-devtools/git/git_2.44.0.bb
+++ b/meta/recipes-devtools/git/git_2.44.0.bb
@@ -40,6 +40,7 @@ EXTRA_OECONF = "--with-perl=${STAGING_BINDIR_NATIVE}/perl-native/perl \
--without-iconv \
"
EXTRA_OECONF:append:class-nativesdk = " --with-gitconfig=/etc/gitconfig "
+EXTRA_OECONF:append:class-native = " --with-gitconfig=/etc/gitconfig "
# Needs brokensep as this doesn't use automake
inherit autotools-brokensep perlnative bash-completion manpages