summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-08-22 17:06:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-03 23:45:53 +0100
commit4d0ab9cd8e330291659e50d8405a8c568165f1b4 (patch)
tree41b05c1ca393fcd828229545698c91880027c6ee
parentcc3c028b64d275912fe2be227e1cebe836b53eb3 (diff)
downloadopenembedded-core-contrib-4d0ab9cd8e330291659e50d8405a8c568165f1b4.tar.gz
rsync: control ipv6 support based on DISTRO_FEATURES
Add PACKAGECONFIG for ipv6 and control it based on DISTRO_FEATURES. (From OE-Core rev: 0a6d496d31383682dbe842b681dc148de1c3158d) Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rsync/rsync.inc2
-rw-r--r--meta/recipes-devtools/rsync/rsync_2.6.9.bb2
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.1.2.bb4
3 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rsync/rsync.inc b/meta/recipes-devtools/rsync/rsync.inc
index 8739c9c620..37897aba80 100644
--- a/meta/recipes-devtools/rsync/rsync.inc
+++ b/meta/recipes-devtools/rsync/rsync.inc
@@ -16,3 +16,5 @@ do_install_append() {
}
EXTRA_OEMAKE='STRIP=""'
+
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
diff --git a/meta/recipes-devtools/rsync/rsync_2.6.9.bb b/meta/recipes-devtools/rsync/rsync_2.6.9.bb
index 5a19e21a03..efdf255a07 100644
--- a/meta/recipes-devtools/rsync/rsync_2.6.9.bb
+++ b/meta/recipes-devtools/rsync/rsync_2.6.9.bb
@@ -11,3 +11,5 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c"
PR = "r4"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
diff --git a/meta/recipes-devtools/rsync/rsync_3.1.2.bb b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
index 798fecc271..c6cb3310fc 100644
--- a/meta/recipes-devtools/rsync/rsync_3.1.2.bb
+++ b/meta/recipes-devtools/rsync/rsync_3.1.2.bb
@@ -9,7 +9,9 @@ SRC_URI[sha256sum] = "ecfa62a7fa3c4c18b9eccd8c16eaddee4bd308a76ea50b5c02a5840f09
LICENSE = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-PACKAGECONFIG ??= "acl attr"
+PACKAGECONFIG ??= "acl attr \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+"
PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"