summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2016-05-30 14:28:12 +1200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2016-06-12 11:33:08 +1200
commit3bf78e6c3743a16ff7b79b4a0a35b6783be830a6 (patch)
treea15e95b312851223e4323e6004a5a2dd1ace1813
parentbf94b2f7e949ffbe806e69c8c4df1010dbf14265 (diff)
downloadopenembedded-core-contrib-3bf78e6c3743a16ff7b79b4a0a35b6783be830a6.tar.gz
Fix listing *_git.bbappend as appends for git recipe
Fix a greedy regex in the recipe detail view resulting in the git recipe listing all bbappends named *_git.bbappend as its bbappends (quite a few in the public instance). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--TODO1
-rw-r--r--layerindex/views.py2
2 files changed, 1 insertions, 2 deletions
diff --git a/TODO b/TODO
index 2d5a53db37..9ab7aa708d 100644
--- a/TODO
+++ b/TODO
@@ -10,7 +10,6 @@ TODO:
* Make it easy to update people's email addresses
Bugs
-* git recipe shows up all _git bbappends: http://layers.openembedded.org/layerindex/recipe/5542/
* Duplication of first maintainer when editing to add a second?
* PROVIDES column appears to be too short for some recipes
diff --git a/layerindex/views.py b/layerindex/views.py
index d0330464b2..d9480c9855 100644
--- a/layerindex/views.py
+++ b/layerindex/views.py
@@ -672,7 +672,7 @@ class RecipeDetailView(DetailView):
verappendprefix = recipe.filename.split('.bb')[0]
appendprefix = verappendprefix.split('_')[0]
#context['verappends'] = BBAppend.objects.filter(layerbranch__branch=recipe.layerbranch.branch).filter(filename='%s.bbappend' % verappendprefix)
- context['appends'] = BBAppend.objects.filter(layerbranch__branch=recipe.layerbranch.branch).filter(filename__regex=r'%s(_[^_]*)?\.bbappend' % appendprefix)
+ context['appends'] = BBAppend.objects.filter(layerbranch__branch=recipe.layerbranch.branch).filter(filename__regex=r'^%s(_[^_]*)?\.bbappend' % appendprefix)
verappends = []
for append in context['appends']:
if append.matches_recipe(recipe):