summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-11-24 12:50:55 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-02 05:24:57 -0800
commit2e95941ef0cc1638f3e4774256a736f3996f63fa (patch)
treee577b9652b4fe8b71d3b1d4af449dc250a93f039
parent032553036dcd0a4b977ab0e4e78b4af4a23e4ad6 (diff)
downloadopenembedded-core-contrib-2e95941ef0cc1638f3e4774256a736f3996f63fa.tar.gz
talloc: add new recipes talloc 2.0.1
talloc is a hierarchical, reference counted memory pool system with destructors. It is the core memory allocator used in Samba. Mesa7.9 also depends on it,so add it for mesa7.9. It is ported from OpenEmbedded, with some format modification. Signed-off-by: Yu Ke <ke.yu@intel.com>
-rw-r--r--meta/recipes-support/talloc/talloc_2.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/talloc/talloc_2.0.1.bb b/meta/recipes-support/talloc/talloc_2.0.1.bb
new file mode 100644
index 0000000000..dfbaf31e08
--- /dev/null
+++ b/meta/recipes-support/talloc/talloc_2.0.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Hierarchical, reference counted memory pool system with destructors"
+HOMEPAGE = "http://talloc.samba.org"
+BUGTRACKER = "https://bugzilla.samba.org/"
+LICENSE = "LGPLv3+"
+LIC_FILES_CHKSUM = "file://talloc.c;beginline=8;endline=26;md5=ea9b6ec07a6d8b3e771f0ec75ca3a317"
+
+PR = "r0"
+
+SRC_URI = "http://samba.org/ftp/${BPN}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "c6e736540145ca58cb3dcb42f91cf57b"
+SRC_URI[sha256sum] = "5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4"
+
+inherit autotools pkgconfig
+
+# autoreconf doesn't work well while reconfiguring included libreplace
+do_configure () {
+ gnu-configize
+ oe_runconf
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+BBCLASSEXTEND = "native"