summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-07-23 17:33:31 +0100
committerJoshua Lock <josh@linux.intel.com>2010-08-02 18:08:30 +0100
commit29b4c2945f50e94a444303241b638ad5a54c0dbc (patch)
tree006e338ced99e33806f6224ac3ec80e773f394ec
parentfa8c028fd005b87ad2e64c5b93221412355d94a6 (diff)
downloadopenembedded-core-contrib-29b4c2945f50e94a444303241b638ad5a54c0dbc.tar.gz
apt: fix builds with modern GCC
Signed-off-by: Joshua Lock <josh@linux.intel.com>
-rw-r--r--meta/packages/apt/apt-0.7.14/includes-fix.patch42
-rw-r--r--meta/packages/apt/apt-native.inc2
-rw-r--r--meta/packages/apt/apt-native_0.7.14.bb9
-rw-r--r--meta/packages/apt/apt.inc4
-rw-r--r--meta/packages/apt/apt_0.7.14.bb5
5 files changed, 53 insertions, 9 deletions
diff --git a/meta/packages/apt/apt-0.7.14/includes-fix.patch b/meta/packages/apt/apt-0.7.14/includes-fix.patch
new file mode 100644
index 0000000000..f4661648ea
--- /dev/null
+++ b/meta/packages/apt/apt-0.7.14/includes-fix.patch
@@ -0,0 +1,42 @@
+Add missing includes required when building with modern toolchain, based on
+patch from Debian bugzilla:
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505954
+
+Should no longer be required once upgraded to 0.7.22 or later.
+
+Index: apt-0.7.14/apt-pkg/acquire.cc
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/acquire.cc 2008-05-28 14:22:13.000000000 +0100
++++ apt-0.7.14/apt-pkg/acquire.cc 2010-07-23 17:30:11.494883936 +0100
+@@ -22,6 +22,7 @@
+
+ #include <apti18n.h>
+
++#include <cstdio>
+ #include <iostream>
+ #include <sstream>
+
+Index: apt-0.7.14/apt-pkg/contrib/sha256.h
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/contrib/sha256.h 2008-05-28 14:22:14.000000000 +0100
++++ apt-0.7.14/apt-pkg/contrib/sha256.h 2010-07-23 17:30:11.494883936 +0100
+@@ -14,6 +14,7 @@
+ #ifndef APTPKG_SHA256_H
+ #define APTPKG_SHA256_H
+
++#include <stdint.h>
+ #include <string>
+ #include <cstring>
+ #include <algorithm>
+Index: apt-0.7.14/apt-pkg/deb/dpkgpm.cc
+===================================================================
+--- apt-0.7.14.orig/apt-pkg/deb/dpkgpm.cc 2008-05-28 14:22:14.000000000 +0100
++++ apt-0.7.14/apt-pkg/deb/dpkgpm.cc 2010-07-23 17:30:36.960856870 +0100
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <fcntl.h>
+ #include <sys/select.h>
++#include <sys/stat.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <signal.h>
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc
index 554ae078fe..b16f99e93c 100644
--- a/meta/packages/apt/apt-native.inc
+++ b/meta/packages/apt/apt-native.inc
@@ -5,7 +5,7 @@ DEPENDS += "dpkg-native gettext-native"
PACKAGES = ""
USE_NLS = "yes"
-SRC_URI += "file://db_linking_hack.patch;patch=1"
+SRC_URI += "file://db_linking_hack.patch"
python do_install () {
bb.build.exec_func('do_install_base', d)
diff --git a/meta/packages/apt/apt-native_0.7.14.bb b/meta/packages/apt/apt-native_0.7.14.bb
index 268e9df720..2f04b72cab 100644
--- a/meta/packages/apt/apt-native_0.7.14.bb
+++ b/meta/packages/apt/apt-native_0.7.14.bb
@@ -1,7 +1,8 @@
require apt-native.inc
-PR = "r2"
+PR = "r3"
-SRC_URI += "file://nodoc.patch;patch=1 \
- file://noconfigure.patch;patch=1 \
- file://no-curl.patch;patch=1"
+SRC_URI += "file://nodoc.patch \
+ file://noconfigure.patch \
+ file://no-curl.patch \
+ file://includes-fix.patch"
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc
index 0913a7fcb4..546683f9bc 100644
--- a/meta/packages/apt/apt.inc
+++ b/meta/packages/apt/apt.inc
@@ -3,8 +3,8 @@ LICENSE = "GPL"
SECTION = "base"
SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
- file://no-ko-translation.patch;patch=1 \
- file://use-host.patch;patch=1 \
+ file://no-ko-translation.patch \
+ file://use-host.patch \
"
inherit autotools gettext
diff --git a/meta/packages/apt/apt_0.7.14.bb b/meta/packages/apt/apt_0.7.14.bb
index 1a9cf3602d..0ea9b48142 100644
--- a/meta/packages/apt/apt_0.7.14.bb
+++ b/meta/packages/apt/apt_0.7.14.bb
@@ -3,9 +3,10 @@ RDEPENDS = "dpkg"
require apt.inc
-PR = "r2"
+PR = "r3"
-SRC_URI += "file://nodoc.patch;patch=1"
+SRC_URI += "file://nodoc.patch \
+ file://includes-fix.patch"
require apt-package.inc