summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-01-14 23:13:37 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-18 07:38:03 -0800
commit20bdd1764f1ee2bc6f9f981d2ea171d79cddf3a5 (patch)
tree9222893293ab60ca18e5ed7dc9b90aa8b186a8f9
parent0b62bd8a95a6500daec6e5fafd5745da74633fc7 (diff)
downloadopenembedded-core-contrib-20bdd1764f1ee2bc6f9f981d2ea171d79cddf3a5.tar.gz
mesa-glsl: add mesa glsl 7.8.2
mesa glsl is required by mesa 7.8.2, so add it. Signed-off-by: Yu Ke <ke.y@intel.com>
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb27
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb25
2 files changed, 27 insertions, 25 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
new file mode 100644
index 0000000000..d6f2c33ea8
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "gl shader language specific build from mesa-dri"
+HOMEPAGE = "http://mesa3d.org"
+BUGTRACKER = "https://bugs.freedesktop.org"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://apps/compile.c;endline=26;md5=27c2833286ce9566b162bcbe21d5b267"
+PR = "r0"
+
+DEPENDS = "makedepend-native"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
+SRC_URI[md5sum] = "6be2d343a0089bfd395ce02aaf8adb57"
+SRC_URI[sha256sum] = "505bf418dceba05837f4ea1b1972b9620c35f8cb94bc4d1e6d573c15f562576d"
+
+S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
+
+inherit native
+
+# use default config for native build
+do_configure_prepend() {
+ ln -s ${S}/../../configs/default ${S}/../../configs/current
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 755 ${S}/apps/compile ${D}/${bindir}/glsl-compile
+}
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb
deleted file mode 100644
index ffc113bfa7..0000000000
--- a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "gl shader language specific build from mesa-dri"
-HOMEPAGE = "http://mesa3d.org"
-BUGTRACKER = "https://bugs.freedesktop.org"
-SECTION = "x11"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://main.cpp;endline=22;md5=a12a9c0208ee64a07ce314dfed4c81eb"
-PR = "r0"
-
-DEPENDS = "makedepend-native talloc-native"
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
-
-S = "${WORKDIR}/Mesa-${PV}/src/glsl"
-
-inherit native
-
-# use default config for native build
-do_configure_prepend() {
- ln -sf ${S}/../../configs/default ${S}/../../configs/current
-}
-
-do_install() {
- install -d ${D}/${bindir}
- install -m 755 ${S}/glsl_compiler ${D}/${bindir}/
-}