summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-07-18 17:58:45 +0000
committerRichard Purdie <richard@openedhand.com>2008-07-18 17:58:45 +0000
commit17268d4c9c016783734b1b0a747d35936157b645 (patch)
tree9c066b7b1a413c0df1ecd3da4f651b037a15687b
parentdc1789a5ab8f3149ca7216397d31d9496a31a660 (diff)
downloadopenembedded-core-contrib-17268d4c9c016783734b1b0a747d35936157b645.tar.gz
linux-omap-2.6.22.19: Apply fixes for gcc 4.3.1 and to fix the pixclock allowed values range
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4885 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/linux/linux-omap-2.6.22.19/fixes.patch66
-rw-r--r--meta/packages/linux/linux-omap_2.6.22.19.bb1
2 files changed, 67 insertions, 0 deletions
diff --git a/meta/packages/linux/linux-omap-2.6.22.19/fixes.patch b/meta/packages/linux/linux-omap-2.6.22.19/fixes.patch
new file mode 100644
index 0000000000..df1bcc71a8
--- /dev/null
+++ b/meta/packages/linux/linux-omap-2.6.22.19/fixes.patch
@@ -0,0 +1,66 @@
+Index: linux-2.6.22.19/arch/arm/Makefile
+===================================================================
+--- linux-2.6.22.19.orig/arch/arm/Makefile 2008-07-18 18:04:40.000000000 +0100
++++ linux-2.6.22.19/arch/arm/Makefile 2008-07-18 18:07:38.000000000 +0100
+@@ -47,7 +47,7 @@
+ # Note that GCC does not numerically define an architecture version
+ # macro, but instead defines a whole series of macros which makes
+ # testing for a specific architecture or later rather impossible.
+-arch-$(CONFIG_CPU_32v7) :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7a,-march=armv5t -Wa$(comma)-march=armv7a)
++arch-$(CONFIG_CPU_32v7) :=-D__LINUX_ARM_ARCH__=7 $(call cc-option,-march=armv7-a,-march=armv5t -Wa$(comma)-march=armv7-a)
+ arch-$(CONFIG_CPU_32v6) :=-D__LINUX_ARM_ARCH__=6 $(call cc-option,-march=armv6,-march=armv5t -Wa$(comma)-march=armv6)
+ # Only override the compiler option if ARMv6. The ARMv6K extensions are
+ # always available in ARMv7
+Index: linux-2.6.22.19/drivers/video/omap/omap_disp_out.c
+===================================================================
+--- linux-2.6.22.19.orig/drivers/video/omap/omap_disp_out.c 2008-07-18 18:53:28.000000000 +0100
++++ linux-2.6.22.19/drivers/video/omap/omap_disp_out.c 2008-07-18 18:53:33.000000000 +0100
+@@ -80,7 +80,7 @@
+ #ifdef CONFIG_FB_OMAP_LCD_VGA
+ #define H4_LCD_XRES 480
+ #define H4_LCD_YRES 640
+-#define H4_LCD_PIXCLOCK_MAX 41700 /* in pico seconds */
++#define H4_LCD_PIXCLOCK_MAX 46295 /* in pico seconds */
+ #define H4_LCD_PIXCLOCK_MIN 38000 /* in pico seconds */
+ #else
+ #ifdef CONFIG_OMAP3430_ES2
+Index: linux-2.6.22.19/include/asm-arm/processor.h
+===================================================================
+--- linux-2.6.22.19.orig/include/asm-arm/processor.h 2008-07-18 18:33:36.000000000 +0100
++++ linux-2.6.22.19/include/asm-arm/processor.h 2008-07-18 18:38:05.000000000 +0100
+@@ -103,14 +103,16 @@
+ #if __LINUX_ARM_ARCH__ >= 5
+
+ #define ARCH_HAS_PREFETCH
+-static inline void prefetch(const void *ptr)
++#define prefetch(ptr) __builtin_prefetch(ptr)
++
++/*static inline void prefetch(const void *ptr)
+ {
+ __asm__ __volatile__(
+- "pld\t%0"
++ "pld\ta%0"
+ :
+- : "o" (*(char *)ptr)
++ : "p" (ptr)
+ : "cc");
+-}
++}*/
+
+ #define ARCH_HAS_PREFETCHW
+ #define prefetchw(ptr) prefetch(ptr)
+Index: linux-2.6.22.19/include/linux/time.h
+===================================================================
+--- linux-2.6.22.19.orig/include/linux/time.h 2008-07-18 18:31:02.000000000 +0100
++++ linux-2.6.22.19/include/linux/time.h 2008-07-18 18:31:36.000000000 +0100
+@@ -171,6 +171,10 @@
+ {
+ ns += a->tv_nsec;
+ while(unlikely(ns >= NSEC_PER_SEC)) {
++ /* The following asm() prevents the compiler from
++ * optimising this loop into a modulo operation. */
++ asm("" : "+r"(ns));
++
+ ns -= NSEC_PER_SEC;
+ a->tv_sec++;
+ }
diff --git a/meta/packages/linux/linux-omap_2.6.22.19.bb b/meta/packages/linux/linux-omap_2.6.22.19.bb
index 8cfdb95017..062ac5321e 100644
--- a/meta/packages/linux/linux-omap_2.6.22.19.bb
+++ b/meta/packages/linux/linux-omap_2.6.22.19.bb
@@ -3,6 +3,7 @@ PR = "r2"
COMPATIBLE_MACHINE = "omap-3430ldp"
SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.22.19.tar.bz2 \
file://defconfig-omap-3430ldp \
+ file://fixes.patch;patch=1 \
file://linux-2.6.22.19-ldp-v1.3.patch.gz;patch=1"
S = "${WORKDIR}/linux-2.6.22.19"