summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Tian <kevin.tian@intel.com>2010-07-23 15:17:06 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 00:01:23 +0100
commit0ff62b0462f3f64672bd4704de9a192eb1a730d1 (patch)
tree1774913dd648d1ae62a4a189ea65b541309d4365
parentf23b594087dba38054a3001e66390d462fa61cbb (diff)
downloadopenembedded-core-contrib-0ff62b0462f3f64672bd4704de9a192eb1a730d1.tar.gz
expat: use gzip-native for unpack
expat 2.0.1 archive is generated with DOS format, which causes CRC error for some version of gzip (<1.4), e.g. on Unbuntu 10.04. This commit adds do_unpack dependency to gzip-native, and thus to use local compiled binary to address this issue. Since 1.4 is a known version solving this issue, also specify a default version for gzip-native also move most lines into expat.inc as cleanup Signed-off-by: Kevin Tian <kevin.tian@intel.com>
-rw-r--r--meta/conf/distro/include/poky-default.inc3
-rw-r--r--meta/packages/expat/expat.inc14
-rw-r--r--meta/packages/expat/expat_2.0.1.bb11
3 files changed, 16 insertions, 12 deletions
diff --git a/meta/conf/distro/include/poky-default.inc b/meta/conf/distro/include/poky-default.inc
index 0df5cf680a..d7d70261fb 100644
--- a/meta/conf/distro/include/poky-default.inc
+++ b/meta/conf/distro/include/poky-default.inc
@@ -42,6 +42,9 @@ PREFERRED_VERSION_glibc-nativesdk ?= "${GLIBCVERSION}"
PREFERRED_VERSION_glibc-initial ?= "${GLIBCVERSION}"
PREFERRED_VERSION_glibc-initial-nativesdk ?= "${GLIBCVERSION}"
PREFERRED_VERSION_elfutils ?= "0.148"
+# don't use version earlier than 1.4 for gzip-native, as it's necessary for
+# some packages using an archive format incompatible with earlier gzip
+PREFERRED_VERSION_gzip-native ?= "1.4"
require conf/distro/include/as-needed.inc
diff --git a/meta/packages/expat/expat.inc b/meta/packages/expat/expat.inc
index d47e340629..8c5010e481 100644
--- a/meta/packages/expat/expat.inc
+++ b/meta/packages/expat/expat.inc
@@ -3,7 +3,17 @@ HOMEPAGE = "http://expat.sourceforge.net/"
SECTION = "libs"
LICENSE = "MIT"
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+ file://autotools.patch"
-inherit autotools
+inherit autotools lib_package
+# This package uses an archive format known to have issue with some
+# versions of gzip
+do_unpack[depends] += "gzip-native:do_populate_sysroot"
+
+do_configure_prepend () {
+ rm -f ${S}/conftools/libtool.m4
+}
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/packages/expat/expat_2.0.1.bb b/meta/packages/expat/expat_2.0.1.bb
index da2682e41f..9983fe5838 100644
--- a/meta/packages/expat/expat_2.0.1.bb
+++ b/meta/packages/expat/expat_2.0.1.bb
@@ -1,12 +1,3 @@
require expat.inc
-PR = "r0"
-
-SRC_URI += "file://autotools.patch;"
-
-inherit lib_package
-do_configure_prepend () {
- rm -f ${S}/conftools/libtool.m4
-}
-
-BBCLASSEXTEND = "native nativesdk"
+PR = "r0"