summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-03-05 10:05:41 +0000
committerRoss Burton <ross@openedhand.com>2007-03-05 10:05:41 +0000
commit01be89c86dfa809fb256d87a3899aa99cfd969ba (patch)
tree5b79a8204f019243002d2bfcadf523ebb0076664
parent3351a60de8d80b04da9ce5d7edaeeefb18f16c21 (diff)
downloadopenembedded-core-contrib-01be89c86dfa809fb256d87a3899aa99cfd969ba.tar.gz
Update to expat 2.0 (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1327 311d38ba-8fff-0310-9ca6-ca027cbcb966
-rw-r--r--meta/packages/expat/expat-2.0.0/autotools.patch13
-rw-r--r--meta/packages/expat/expat.inc13
-rw-r--r--meta/packages/expat/expat_1.95.7.bb12
-rw-r--r--meta/packages/expat/expat_2.0.0.bb27
4 files changed, 56 insertions, 9 deletions
diff --git a/meta/packages/expat/expat-2.0.0/autotools.patch b/meta/packages/expat/expat-2.0.0/autotools.patch
new file mode 100644
index 0000000000..77aee3a833
--- /dev/null
+++ b/meta/packages/expat/expat-2.0.0/autotools.patch
@@ -0,0 +1,13 @@
+diff -bur expat-2.0.0~orig/configure.in expat-2.0.0/configure.in
+--- expat-2.0.0~orig/configure.in 2006-01-10 19:10:46.000000000 -0600
++++ expat-2.0.0/configure.in 2006-02-10 19:12:24.000000000 -0600
+@@ -50,9 +50,6 @@
+
+ AC_CONFIG_HEADER(expat_config.h)
+
+-sinclude(conftools/libtool.m4)
+-sinclude(conftools/ac_c_bigendian_cross.m4)
+-
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
+
diff --git a/meta/packages/expat/expat.inc b/meta/packages/expat/expat.inc
new file mode 100644
index 0000000000..6d27b77b19
--- /dev/null
+++ b/meta/packages/expat/expat.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Jim Clarkes XML parser library."
+HOMEPAGE = "http://expat.sf.net/"
+SECTION = "libs"
+LICENSE = "MIT"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/expat-${PV}"
+
+export LTCC = "${CC}"
+
+inherit autotools
+
diff --git a/meta/packages/expat/expat_1.95.7.bb b/meta/packages/expat/expat_1.95.7.bb
index c3bbb8981b..a4dda4dcb6 100644
--- a/meta/packages/expat/expat_1.95.7.bb
+++ b/meta/packages/expat/expat_1.95.7.bb
@@ -1,15 +1,9 @@
-SECTION = "libs"
-DESCRIPTION = "Jim Clarkes XML parser library."
-HOMEPAGE = "http://expat.sourceforge.net/"
-LICENSE = "MIT"
+require expat.inc
PR = "r1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.gz \
- file://autotools.patch;patch=1"
-S = "${WORKDIR}/expat-${PV}"
+SRC_URI += "file://autotools.patch;patch=1"
-inherit autotools lib_package
-export LTCC = "${CC}"
+inherit lib_package
do_configure () {
rm -f ${S}/conftools/libtool.m4
diff --git a/meta/packages/expat/expat_2.0.0.bb b/meta/packages/expat/expat_2.0.0.bb
new file mode 100644
index 0000000000..0fd825ee24
--- /dev/null
+++ b/meta/packages/expat/expat_2.0.0.bb
@@ -0,0 +1,27 @@
+require expat.inc
+PR = "r2"
+
+SRC_URI += "file://autotools.patch;patch=1"
+
+inherit lib_package
+
+do_configure() {
+ rm -f ${S}/conftools/libtool.m4
+ touch ${S}/conftools/libtool.m4
+ autotools_do_configure
+}
+
+do_stage() {
+ install -m 0644 ${S}/lib/expat.h ${STAGING_INCDIR}/
+ install -m 0644 ${S}/lib/expat_external.h ${STAGING_INCDIR}/
+ oe_libinstall -so libexpat ${STAGING_LIBDIR}
+}
+
+do_install() {
+ oe_runmake prefix="${D}${prefix}" \
+ bindir="${D}${bindir}" \
+ libdir="${D}${libdir}" \
+ includedir="${D}${includedir}" \
+ man1dir="${D}${mandir}/man1" \
+ install
+}