summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 18:10:07 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 18:49:03 -0800
commit7790d9b16011aec9551dbb526d6e558772670165 (patch)
tree171696594ebfed516468de41dd44601ac6bbda24
parent87d8b0ef8acfbf953176808063a2a3dbdb55255a (diff)
downloadopenembedded-core-contrib-timo/add-pytest-to-oe-core.tar.gz
python3-pytest: RDEPENDS on python3-tomltimo/add-pytest-to-oe-core
The generated requires.txt in pytest-*-py3.9.egg-info shows the requirement. Caught during ptest of python3-wcwidth: Signed-off-byROR collecting tests/test_core.py ______________________ tests/test_core.py:4: in <module> import pkg_resources ../../python3.9/site-packages/pkg_resources/__init__.py:3239: in <module> def _initialize_master_working_set(): ../../python3.9/site-packages/pkg_resources/__init__.py:3222: in _call_aside f(*args, **kwargs) ../../python3.9/site-packages/pkg_resources/__init__.py:3251: in _initialize_master_working_set working_set = WorkingSet._build_master() ../../python3.9/site-packages/pkg_resources/__init__.py:567: in _build_master ws.require(__requires__) ../../python3.9/site-packages/pkg_resources/__init__.py:884: in require needed = self.resolve(parse_requirements(requirements)) ../../python3.9/site-packages/pkg_resources/__init__.py:770: in resolve raise DistributionNotFound(req, requirers) E pkg_resources.DistributionNotFound: The 'toml' distribution was not found and is required by pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-pytest_6.1.2.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest_6.1.2.bb b/meta/recipes-devtools/python/python3-pytest_6.1.2.bb
index 6872da5cfa..6fc3b6f328 100644
--- a/meta/recipes-devtools/python/python3-pytest_6.1.2.bb
+++ b/meta/recipes-devtools/python/python3-pytest_6.1.2.bb
@@ -10,21 +10,22 @@ SRC_URI[sha256sum] = "c0a7e94a8cdbc5422a51ccdad8e6f1024795939cc89159a0ae7f0b316a
inherit update-alternatives pypi setuptools3
RDEPENDS_${PN}_class-target += " \
+ ${PYTHON_PN}-atomicwrites \
${PYTHON_PN}-attrs \
${PYTHON_PN}-debugger \
${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-importlib-metadata \
${PYTHON_PN}-iniconfig \
${PYTHON_PN}-json \
+ ${PYTHON_PN}-more-itertools \
+ ${PYTHON_PN}-packaging \
+ ${PYTHON_PN}-pathlib2 \
${PYTHON_PN}-pluggy \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
- ${PYTHON_PN}-atomicwrites \
- ${PYTHON_PN}-importlib-metadata \
- ${PYTHON_PN}-pathlib2 \
+ ${PYTHON_PN}-toml \
${PYTHON_PN}-wcwidth \
- ${PYTHON_PN}-more-itertools \
- ${PYTHON_PN}-packaging \
"
ALTERNATIVE_${PN} += "py.test pytest"