aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2018-12-27 00:38:49 -0800
committerRobert Yang <liezhi.yang@windriver.com>2018-12-28 01:00:21 -0800
commit6d9b2cd317e178c70af2610ad3de9d05c6eaf4a3 (patch)
tree75a1c735a7aca705e39a67c541e2e9a076b16e90
parent9d76d528a82a49e0d524475c4a02c701b43eed3c (diff)
downloadopenembedded-core-contrib-rbt/race.tar.gz
perl: Fix race issue for cpan/Pod-Simplerbt/race
Fixed: Running pm_to_blib for cpan/Pod-Simple directly [snip] /path/to/cpan/podlators/../../miniperl "-I../../lib" "-I../../lib" -MExtUtils::MY -e 'MY->fixin(shift)' -- blib/script/pod2man Can't locate Getopt/Long.pm in @INC [snip] Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.4.bb1
-rw-r--r--meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch34
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.4.bb1
3 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.4.bb b/meta/recipes-devtools/perl/perl-native_5.24.4.bb
index 81d3fd4898..fe44d9b8e8 100644
--- a/meta/recipes-devtools/perl/perl-native_5.24.4.bb
+++ b/meta/recipes-devtools/perl/perl-native_5.24.4.bb
@@ -17,6 +17,7 @@ SRC_URI += "\
file://0001-Configure-Remove-fstack-protector-strong-for-native-.patch \
file://perl-5.26.1-guard_old_libcrypt_fix.patch \
file://0001-ExtUtils-MM_Unix.pm-fix-race-issues.patch \
+ file://0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch \
"
SRC_URI[md5sum] = "04622bc4d3941dc7eb571c52b7c02993"
diff --git a/meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch b/meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch
new file mode 100644
index 0000000000..aad46f3e42
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl/0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch
@@ -0,0 +1,34 @@
+From 58c69d65b19b5f9a35e1f5ce08d2ea47884233d3 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 27 Dec 2018 00:18:51 -0800
+Subject: [PATCH] Makefile.SH: Pod-Simple requires Getopt-Long
+
+Fixed a race issue when parallel build:
+
+Running pm_to_blib for cpan/Pod-Simple directly
+[snip]
+/path/to/cpan/podlators/../../miniperl "-I../../lib" "-I../../lib" -MExtUtils::MY -e 'MY->fixin(shift)' -- blib/script/pod2man
+Can't locate Getopt/Long.pm in @INC [snip]
+
+Upstream-Status: Submitted[https://www.nntp.perl.org/group/perl.perl5.porters/2018/12/msg253236.html]
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ Makefile.SH | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.SH b/Makefile.SH
+index 9848d55..7a164e7 100755
+--- a/Makefile.SH
++++ b/Makefile.SH
+@@ -189,6 +189,7 @@ dynamic_list=' '
+ dynamic_ext_re="lib/auto/re/re.$dlext"
+ extra_dep='
+ ext/Pod-Functions/pm_to_blib: cpan/Pod-Simple/pm_to_blib cpan/Pod-Escapes/pm_to_blib pod/perlfunc.pod
++cpan/Pod-Simple/pm_to_blib: cpan/Getopt-Long/pm_to_blib
+ '
+ for f in $dynamic_ext; do
+ : the dependency named here will never exist
+--
+2.10.2
+
diff --git a/meta/recipes-devtools/perl/perl_5.24.4.bb b/meta/recipes-devtools/perl/perl_5.24.4.bb
index a644970192..7b1ae7fec9 100644
--- a/meta/recipes-devtools/perl/perl_5.24.4.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.4.bb
@@ -65,6 +65,7 @@ SRC_URI += " \
file://perl-5.26.1-guard_old_libcrypt_fix.patch \
file://CVE-2018-12015.patch \
file://0001-ExtUtils-MM_Unix.pm-fix-race-issues.patch \
+ file://0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch \
"
# Fix test case issues