aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-26 02:05:17 -0800
committerRobert Yang <liezhi.yang@windriver.com>2015-11-26 17:28:13 -0800
commitb817f6b15376e9fc95c6ab50c6dae825a6c81ce6 (patch)
treec335d989d0b0bbf8f4f4b8e87275fe70c44a21b3
parent80b3974081c4a8c604e23982a6db8fb32c616058 (diff)
downloadopenembedded-core-contrib-rbt/n32.tar.gz
rpm: fix for N32 MIPS64rbt/n32
Issue: LIN8-1726 Older versions of 'file' reported it as N32 MIPS32, newer versions are reporting it as N32 MIPS64. So we should check for both. $ file image/usr/bin/getent getent: ELF 32-bit MSB executable, MIPS, N32 MIPS64 [snip] (LOCAL REV: NOT UPSTREAM) -- Sent to oe-core on 20151126 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-rpmfc.c-fix-for-N32-MIPS64.patch33
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4+cvs.bb1
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb1
3 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-rpmfc.c-fix-for-N32-MIPS64.patch b/meta/recipes-devtools/rpm/rpm/rpm-rpmfc.c-fix-for-N32-MIPS64.patch
new file mode 100644
index 0000000000..99cdf85f54
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-rpmfc.c-fix-for-N32-MIPS64.patch
@@ -0,0 +1,33 @@
+From e864ec768ad0736bddcd951b2db8fe12c7b30e4e Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 26 Nov 2015 01:36:40 -0800
+Subject: [PATCH] lib/rpmfc.c: fix for N32 MIPS64
+
+Older versions of 'file' reported it as N32 MIPS32, newer versions are
+reporting it as N32 MIPS64. So we should check for both.
+
+$ file image/usr/bin/getent
+getent: ELF 32-bit MSB executable, MIPS, N32 MIPS64 [snip]
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ lib/rpmfc.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/lib/rpmfc.c b/lib/rpmfc.c
+index fde00c7..c9c82bf 100644
+--- a/lib/rpmfc.c
++++ b/lib/rpmfc.c
+@@ -575,6 +575,7 @@ static struct rpmfcTokens_s rpmfcTokens[] = {
+ { " not stripped", RPMFC_NOTSTRIPPED },
+ { " archive", RPMFC_ARCHIVE },
+
++ { "MIPS, N32 MIPS64", RPMFC_ELFMIPSN32|RPMFC_INCLUDE },
+ { "MIPS, N32 MIPS32", RPMFC_ELFMIPSN32|RPMFC_INCLUDE },
+ { "ELF 32-bit", RPMFC_ELF32|RPMFC_INCLUDE },
+ { "ELF 64-bit", RPMFC_ELF64|RPMFC_INCLUDE },
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
index 951b2517f0..0d14728908 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
@@ -111,6 +111,7 @@ SRC_URI = "cvs://anonymous@rpm5.org/cvs;tag=rpm-5_4;module=rpm \
file://rpm-rpmpgp-fix.patch \
file://rpm-disable-Wno-override-init.patch \
file://rpm-realpath.patch \
+ file://rpm-rpmfc.c-fix-for-N32-MIPS64.patch \
"
# Uncomment the following line to enable platform score debugging
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
index 39304103ea..8e1d3cbfc6 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.14.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -101,6 +101,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;e
file://rpm-opendb-before-verifyscript-to-avoid-null-point.patch \
file://configure.ac-check-for-both-gpg2-and-gpg.patch \
file://0001-define-EM_AARCH64.patch \
+ file://rpm-rpmfc.c-fix-for-N32-MIPS64.patch \
"
# Uncomment the following line to enable platform score debugging