aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-26 18:35:05 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-04-26 19:15:47 -0700
commit75bc093f2baf23824118d59164a099da025aa105 (patch)
treefd135597da0eb9636c2a5462cb1b9e5ac618e058
parent848a900f933989bffc430176cd1f38292484ccae (diff)
downloadopenembedded-core-contrib-rbt/lic.tar.gz
libxsettings-client: fix COPYING filerbt/lic
Fixed: * Move the code of copy COPYING file from do_configure_append() to do_patch[postfuncs] since we had moved license-checksum from do_package_qa to do_populate_lic. * Add xsettings-client.c and xsettings-common.c to LIC_FILES_CHKSUM. * Update comments. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
index 67c5e27776..9e9336e5db 100644
--- a/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
+++ b/meta/recipes-graphics/libxsettings-client/libxsettings-client_0.10.bb
@@ -9,7 +9,9 @@ SECTION = "x/libs"
LICENSE = "MIT-style"
LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
- file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
+ file://xsettings-client.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \
+ file://xsettings-common.c;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b"
DEPENDS = "virtual/libx11"
PR = "r5"
@@ -31,10 +33,11 @@ inherit autotools gettext distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-do_configure_prepend() {
- # This package doesn't ship with its own COPYING file and
- # autotools will install a GPLv2 one instead of the actual MIT-style license here.
- # Add the correct license here to avoid confusion.
+do_patch[postfuncs] += "update_copying_file"
+update_copying_file() {
+ # This package ships with a GPLv2 COPYING file, but the author says
+ # it is actual MIT-style license, add the correct license here to
+ # avoid confusion.
cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING
}