aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-12-09 00:22:44 -0800
committerRobert Yang <liezhi.yang@windriver.com>2016-12-09 00:29:37 -0800
commita27415050670fcb77888e9a8a770c1e4c4d63246 (patch)
treed1ed4264ceed5d6ccbdc759f82fa1e39fd2b0931
parenta9db40da62c13b0010ce5afc1fde16d987bdfbc6 (diff)
downloadopenembedded-core-contrib-rbt/jethro-next.tar.gz
selftest/recipetool.py: set srcrev for recipetool createrbt/jethro-next
The srcrev would default to master when not set, which may cause erorrs when the source is changed. Fixed: ====================================================================== FAIL: test_recipetool_create_git (oeqa.selftest.recipetool.RecipetoolTests) ---------------------------------------------------------------------- Traceback (most recent call last): File "/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/meta/lib/oeqa/utils/decorators.py", line 106, in wrapped_f return func(*args, **kwargs) File "/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/meta/lib/oeqa/selftest/recipetool.py", line 402, in test_recipetool_create_git self._test_recipe_contents(recipefile, checkvars, inherits) File "/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-oe-selftest/build/meta/lib/oeqa/selftest/devtool.py", line 25, in _test_recipe_contents self.assertEqual(value, needvalue, 'values for %s do not match' % var) AssertionError: 'Unknown LGPLv2.1' != 'LGPLv2.1' : values for LICENSE do not match The rev=9f7cf8895ae2d39c465c04cc78e918c157420269 is taken from master branch. It was failed because libmatchbox's master branch has added a COPYING.MIT, and the testcase only checks COPYING. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/lib/oeqa/selftest/recipetool.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/lib/oeqa/selftest/recipetool.py b/meta/lib/oeqa/selftest/recipetool.py
index b1f1d2ab90..d15820c3b4 100644
--- a/meta/lib/oeqa/selftest/recipetool.py
+++ b/meta/lib/oeqa/selftest/recipetool.py
@@ -389,7 +389,7 @@ class RecipetoolTests(RecipetoolBase):
os.makedirs(tempsrc)
recipefile = os.path.join(self.tempdir, 'libmatchbox.bb')
srcuri = 'git://git.yoctoproject.org/libmatchbox'
- result = runCmd('recipetool create -o %s %s -x %s' % (recipefile, srcuri, tempsrc))
+ result = runCmd('recipetool create -o %s "%s;rev=9f7cf8895ae2d39c465c04cc78e918c157420269" -x %s' % (recipefile, srcuri, tempsrc))
self.assertTrue(os.path.isfile(recipefile), 'recipetool did not create recipe file; output:\n%s' % result.output)
checkvars = {}
checkvars['LICENSE'] = 'LGPLv2.1'