summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2020-01-03 17:58:58 +0800
committerRobert Yang <liezhi.yang@windriver.com>2020-01-06 18:25:36 +0800
commit281727c8444cda2b543f94e43f947e1cdc018be0 (patch)
treef166d468e467151ba5edef761e536fa899084b63
parent53cf1241fa4721ba89955146099749d05c5d7171 (diff)
downloadopenembedded-core-contrib-rbt/gnupg.tar.gz
gnupg: Read GNUPG_BINDIR from environment variables for nativesdkrbt/gnupg
There is already a relocate.patch for native which is used for reading GNUPG_BINDIR from environment variables, now also enable it for nativesdk. Otherwise, command like the following one doesn't work for nativesdk: $ gpg-connect-agent --homedir ../keys/ reloadagent /bye gpg-connect-agent: no running gpg-agent - starting '/opt/path/to/sysroots/x86_64-wrlinuxsdk-linux/usr/bin/gpg-agent' gpg-connect-agent: failed to start agent '/opt/path/sysroots/x86_64-wrlinuxsdk-linux/usr/bin/gpg-agent': No such file or directory Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.2.17.bb17
1 files changed, 13 insertions, 4 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.2.17.bb b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
index bb8885f1c8..0a939cf3ec 100644
--- a/meta/recipes-support/gnupg/gnupg_2.2.17.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.2.17.bb
@@ -19,6 +19,8 @@ SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
file://relocate.patch"
+SRC_URI_append_class-nativesdk = " file://relocate.patch"
+
SRC_URI[md5sum] = "1ba2d9b70c377f8e967742064c27a19c"
SRC_URI[sha256sum] = "afa262868e39b651a2db4c071fba90415154243e83a830ca00516f9a807fd514"
@@ -60,10 +62,17 @@ do_install_append() {
}
do_install_append_class-native() {
- create_wrapper ${D}${bindir}/gpg2 GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpgconf GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpg-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
- create_wrapper ${D}${bindir}/gpg-connect-agent GNUPG_BINDIR=${STAGING_BINDIR_NATIVE}
+ create_wrappers ${STAGING_BINDIR_NATIVE}
+}
+
+do_install_append_class-nativesdk() {
+ create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
+}
+
+create_wrappers() {
+ for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
+ create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
+ done
}
PACKAGECONFIG ??= "gnutls"