summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-20 18:52:05 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-07-23 22:15:21 -0700
commit07cae7b73779e89d5e038bf48fbfa204d51b4b68 (patch)
tree6b838d13c03b031ee02398af178c910a8654e3cc
parent0a2df616a5c3316704742f1dcf37b450920e0280 (diff)
downloadopenembedded-core-contrib-rbt/epiphany.tar.gz
openembedded-core-contrib-rbt/epiphany.tar.bz2
openembedded-core-contrib-rbt/epiphany.zip
epiphany: inherit perlnativerbt/epiphany
Fixed: checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool The module is installed to sysroot, but need use native perl to find it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.20.3.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.20.3.bb b/meta/recipes-gnome/epiphany/epiphany_3.20.3.bb
index eba480b2f6..a61e2cf586 100644
--- a/meta/recipes-gnome/epiphany/epiphany_3.20.3.bb
+++ b/meta/recipes-gnome/epiphany/epiphany_3.20.3.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes ca-certificates avahi libnotify gcr libwnck3 \
gsettings-desktop-schemas gnome-desktop3 libxml2-native intltool-native"
-inherit gnomebase gsettings distro_features_check upstream-version-is-even
+inherit gnomebase gsettings distro_features_check upstream-version-is-even perlnative
# libwnck3 is x11 only
REQUIRED_DISTRO_FEATURES = "x11"
@@ -22,4 +22,3 @@ do_configure_prepend() {
FILES_${PN} += "${datadir}/appdata ${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers"
RDEPENDS_${PN} = "iso-codes adwaita-icon-theme"
RRECOMMENDS_${PN} = "ca-certificates"
-