aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-01-19 04:42:14 -0500
committerDengke Du <dengke.du@windriver.com>2016-01-20 04:03:07 -0500
commit2a8d19d4ef60a323c8770722ec7f60811ced53ca (patch)
tree3208e8c854dd1a72051be7f69acdfa4bf7be3e8f
parent68c7113a746694e25df2ac5d86171ed96b7c2e94 (diff)
downloadopenembedded-core-contrib-dengke/ncurses_drop_compatible_option.tar.gz
ncurses: drop the compatible optiondengke/ncurses_drop_compatible_option
drop the compatible option --with-abi-version=5 Signed-off-by: Dengke Du <dengke.du@windriver.com>
-rw-r--r--meta/recipes-core/ncurses/ncurses.inc10
-rw-r--r--meta/recipes-core/ncurses/ncurses_6.0.bb1
2 files changed, 5 insertions, 6 deletions
diff --git a/meta/recipes-core/ncurses/ncurses.inc b/meta/recipes-core/ncurses/ncurses.inc
index fbe74d5925..0ebf8d502a 100644
--- a/meta/recipes-core/ncurses/ncurses.inc
+++ b/meta/recipes-core/ncurses/ncurses.inc
@@ -7,7 +7,7 @@ SECTION = "libs"
DEPENDS = "ncurses-native"
DEPENDS_class-native = ""
-BINCONFIG = "${bindir}/ncurses5-config ${bindir}/ncursesw5-config"
+BINCONFIG = "${bindir}/ncurses6-config ${bindir}/ncursesw6-config"
inherit autotools binconfig-disabled multilib_header pkgconfig
@@ -205,7 +205,7 @@ do_install() {
test -h $f || continue
rm -f $f
echo '/* GNU ld script */' >$f
- echo "INPUT($i.so.5 AS_NEEDED(-ltinfo))" >>$f
+ echo "INPUT($i.so.6 AS_NEEDED(-ltinfo))" >>$f
done
# Make sure that libcurses is linked so that it gets -ltinfo
@@ -231,7 +231,7 @@ do_install() {
# Use lnr to ensure this is a relative link despite absolute paths
# (as we can't know the relationship between base_libdir and libdir).
# At some point we can rely on coreutils 8.16 which has ln -r.
- lnr ${D}${base_libdir}/libtinfo.so.5 ${D}${libdir}/libtinfo.so
+ lnr ${D}${base_libdir}/libtinfo.so.6 ${D}${libdir}/libtinfo.so
fi
if [ -d "${D}${includedir}/ncurses" ]; then
for f in `find ${D}${includedir}/ncurses -name "*.h"`
@@ -271,8 +271,8 @@ PACKAGES += " \
FILES_${PN} = "\
${bindir}/tput \
${bindir}/tset \
- ${bindir}/ncurses5-config \
- ${bindir}/ncursesw5-config \
+ ${bindir}/ncurses6-config \
+ ${bindir}/ncursesw6-config \
${datadir}/tabset \
"
diff --git a/meta/recipes-core/ncurses/ncurses_6.0.bb b/meta/recipes-core/ncurses/ncurses_6.0.bb
index 8587287542..ea45ea75c4 100644
--- a/meta/recipes-core/ncurses/ncurses_6.0.bb
+++ b/meta/recipes-core/ncurses/ncurses_6.0.bb
@@ -8,4 +8,3 @@ SRC_URI += "file://tic-hang.patch \
# commit id corresponds to the above listed REVISION
SRCREV = "c6b034b4d69f8c9092c2a1b5d5bb718282b2a522"
S = "${WORKDIR}/git"
-EXTRA_OECONF += "--with-abi-version=5"