aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-03-17 05:08:00 -0400
committerDengke Du <dengke.du@windriver.com>2016-03-17 05:08:00 -0400
commit2dafd64ba837f262174d2e66c05305d4ce1d77e3 (patch)
treebf402d16ec44e324d90dab2d106a9093e5b652ff
parent8debfea81e69d038bd2d56314b272cb74f5582ed (diff)
downloadopenembedded-core-contrib-dengke/nativesdk-coreutils_many_warnings_fixed.tar.gz
nativesdk-coreutils: a lot of warningsdengke/nativesdk-coreutils_many_warnings_fixed
When create nativesdk-coreutils, appear a lot of warnings, because necessary file(used to package) disappear when the system to check them using the update-alternative. So it should add the necessary files in the do_install_append() for class-nativesdk. Signed-off-by: Dengke Du <dengke.du@windriver.com>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.25.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.25.bb b/meta/recipes-core/coreutils/coreutils_8.25.bb
index 650008e528..a370d71606 100644
--- a/meta/recipes-core/coreutils/coreutils_8.25.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.25.bb
@@ -27,6 +27,7 @@ SRC_URI[manpages.sha256sum] = "2ee31c3a6d2276f49c5515375d4a0c1047580da6ac1053689
EXTRA_OECONF_class-native = "--without-gmp"
EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
+EXTRA_OECONF_class-nativesdk = "--enable-install-program=arch"
# acl and xattr are not default features
#
@@ -67,7 +68,11 @@ do_compile_prepend () {
mkdir -p ${B}/src
}
-do_install_append_class-target() {
+do_install_append() {
+ if [ "${CLASSOVERRIDE}" = "class-native" ]; then
+ return
+ fi
+
for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
install -d ${D}${base_bindir}