aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-07-26 05:23:59 -0400
committerDengke Du <dengke.du@windriver.com>2016-07-27 00:57:51 -0400
commit63d457eb9aeb264ae65e31c1e78f8024609a38c3 (patch)
treeb2896f562aa35a5aca3e58eba9bfbece7f9ed7ac
parentca348367ce951e066d14aaed4323e9cd36e8827a (diff)
downloadopenembedded-core-contrib-dengke/enable-help-man-pages-for-perf.tar.gz
perf: enable man pages for 'help' functionalitydengke/enable-help-man-pages-for-perf
When using 'perf help <subcommand>', it can't find 'man' command and pages for perf. The perf man pages depends on the xmlto-native and asciidoc-native, so we just need to add the two packages to the DEPENDS variable and add 'man'to RDEPENDS_perf-doc. Signed-off-by: Dengke Du <dengke.du@windriver.com>
-rw-r--r--meta/recipes-kernel/perf/perf.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 171d23f454..1e84a2231b 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -30,6 +30,8 @@ DEPENDS = " \
${SCRIPTING_DEPENDS} \
${LIBUNWIND_DEPENDS} \
bison flex xz \
+ xmlto-native \
+ asciidoc-native \
"
do_configure[depends] += "virtual/kernel:do_shared_workdir"
@@ -90,7 +92,6 @@ EXTRA_OEMAKE += "\
'sharedir=${datadir}' \
'sysconfdir=${sysconfdir}' \
'perfexecdir=${libexecdir}/perf-core' \
- \
'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
'sharedir=${@os.path.relpath(datadir, prefix)}' \
'mandir=${@os.path.relpath(mandir, prefix)}' \
@@ -138,6 +139,13 @@ do_configure_prepend () {
-e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
${S}/tools/perf/config/Makefile
fi
+ # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
+ # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
+ # will use the relative path 'share/man', in the way it will resulting in
+ # incorrect installation for man pages.
+ if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
+ sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
+ fi
if [ -e "${S}/tools/perf/Makefile.perf" ]; then
sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
${S}/tools/perf/Makefile.perf
@@ -197,6 +205,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
RDEPENDS_${PN} += "elfutils bash"
+RDEPENDS_${PN}-doc += "man"
RDEPENDS_${PN}-archive =+ "bash"
RDEPENDS_${PN}-python =+ "bash python python-modules"
RDEPENDS_${PN}-perl =+ "bash perl perl-modules"