summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2022-03-21 10:13:23 -0600
committerDaniel McGregor <daniel.mcgregor@vecima.com>2023-10-04 12:49:49 -0600
commit4ae7f0ae72b3034cae164518ca8c384d2ef0eaec (patch)
tree2c174b89d436213d6177a8ef01808a7f7c22200a
parent9104fe502c7361fd4efef997d6e45a48e43eb637 (diff)
downloadopenembedded-core-contrib-dankm/vecima/misc.tar.gz
systemd: generate manpages indexesdankm/vecima/misc
Now that python3-lxml is in core, use it to generate systemd.directives and systemd.index manual pages. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
-rw-r--r--meta/recipes-core/systemd/systemd_254.4.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_254.4.bb b/meta/recipes-core/systemd/systemd_254.4.bb
index 77724eb822..99c1a662f9 100644
--- a/meta/recipes-core/systemd/systemd_254.4.bb
+++ b/meta/recipes-core/systemd/systemd_254.4.bb
@@ -173,7 +173,10 @@ PACKAGECONFIG[localed] = "-Dlocaled=true,-Dlocaled=false"
PACKAGECONFIG[logind] = "-Dlogind=true,-Dlogind=false"
PACKAGECONFIG[lz4] = "-Dlz4=true,-Dlz4=false,lz4"
PACKAGECONFIG[machined] = "-Dmachined=true,-Dmachined=false"
-PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
+PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,python3-lxml-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
+# Ensure we're seeing the XML catalog from the build system and not the host.
+# Otherwise, the build may fail generating the manpages.
+export XML_CATALOG_FILES="${STAGING_ETCDIR_NATIVE}/xml/catalog"
PACKAGECONFIG[microhttpd] = "-Dmicrohttpd=true,-Dmicrohttpd=false,libmicrohttpd"
PACKAGECONFIG[myhostname] = "-Dnss-myhostname=true,-Dnss-myhostname=false,,libnss-myhostname"
PACKAGECONFIG[networkd] = "-Dnetworkd=true,-Dnetworkd=false"