aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-01-12 17:17:48 -0600
committerDan McGregor <dan.mcgregor@usask.ca>2016-01-14 14:22:48 -0600
commit0bec895ab2fbd518bae7f3366019829b54a3a2ce (patch)
tree29e0862b2640cc6814004bdeb4407501210839c6
parent3c129d2250a6c80a125fc865bf8d9b55b02b9b05 (diff)
downloadopenembedded-core-contrib-dankm/libdir.tar.gz
opkg-utils: store alternatives in nonarch_libdirdankm/libdir
opkg-utils-native stores alternative info in /usr/lib, so do the same on the target. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com>
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index b242d1f3fb..1bc561c08a 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -34,7 +34,7 @@ do_install() {
do_install_append_class-target() {
if [ -e "${D}${bindir}/update-alternatives" ]; then
- sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${libdir},g'
+ sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
fi
}