aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-08-07 02:58:12 -0400
committerChen Qi <Qi.Chen@windriver.com>2014-08-07 16:29:07 +0800
commit2c23e2ba5fed7c0b33ba9cbd6bea6aa109063890 (patch)
tree43d282b37c009eb0e67c85dd62db3174f8b5878c
parent7ac62381a30c4d0031b6eb48d25d5ccb1bc8a1ed (diff)
downloadopenembedded-core-contrib-ChenQi/systemd_alsa-state_v86d.tar.gz
v86d: fix for systemd to load uvesafb module correctlyChenQi/systemd_alsa-state_v86d
The /etc/init.d/fbsetup script doesn't have any effect in a systemd image. Its purpose is to load the uvesafb kernel module at boot. This functionality could be achieved by adding a configuration file under /etc/modules-load.d/ directory which would be parsed by the systemd-modules-load.service. [YOCTO #4420] Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-bsp/v86d/v86d/uvesafb.conf2
-rw-r--r--meta/recipes-bsp/v86d/v86d_0.1.10.bb14
2 files changed, 14 insertions, 2 deletions
diff --git a/meta/recipes-bsp/v86d/v86d/uvesafb.conf b/meta/recipes-bsp/v86d/v86d/uvesafb.conf
new file mode 100644
index 0000000000..43789755d3
--- /dev/null
+++ b/meta/recipes-bsp/v86d/v86d/uvesafb.conf
@@ -0,0 +1,2 @@
+# Load uvesafb.ko at boot
+uvesafb
diff --git a/meta/recipes-bsp/v86d/v86d_0.1.10.bb b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
index b980331ac3..08438bea47 100644
--- a/meta/recipes-bsp/v86d/v86d_0.1.10.bb
+++ b/meta/recipes-bsp/v86d/v86d_0.1.10.bb
@@ -12,6 +12,7 @@ PR = "r2"
SRC_URI = "http://distfiles.gentoo.org/distfiles/${BP}.tar.bz2 \
file://Update-x86emu-from-X.org.patch \
file://fbsetup \
+ file://uvesafb.conf \
file://ar-from-env.patch"
SRC_URI[md5sum] = "51c792ba7b874ad8c43f0d3da4cfabe0"
@@ -35,8 +36,17 @@ do_install () {
install -d ${D}${base_sbindir}
install v86d ${D}${base_sbindir}/
- install -d ${D}${sysconfdir}/init.d/
- install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
+ # Only install fbsetup script if 'sysvinit' is in DISTRO_FEATURES
+ if ${@bb.utils.contains('DISTRO_FEATURES','sysvinit','true','false',d)}; then
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fbsetup ${D}${sysconfdir}/init.d/fbsetup
+ fi
+
+ # Install systemd related configuration file
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}${sysconfdir}/modules-load.d
+ install -m 0644 ${WORKDIR}/uvesafb.conf ${D}${sysconfdir}/modules-load.d
+ fi
}
inherit update-rc.d