aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-07-21 16:57:51 +0800
committerChen Qi <Qi.Chen@windriver.com>2014-07-22 10:37:39 +0800
commite507facc9bf56040f966942677f550f4ee321baf (patch)
treed21e21d0b5220242ad07e01f9c6b26865d355129
parent5bcda42a946ae8b14aee8864d18745be0a997aaa (diff)
downloadopenembedded-core-contrib-ChenQi/systemd-udev-hwdb.tar.gz
systemd: change dependency relationshipsChenQi/systemd-udev-hwdb
When building out a systemd based image, the udev-hwdb postinstall script always fails at rootfs time. This is because that the 'udevadm' command used in udev-hwdb postinstall script is now in the udev package and udev recommends udev-hwdb. Instead of letting udev recommends udev-hwdb, we let systemd do it and make udev-hwdb rdepend on udev. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd_213.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd_213.bb b/meta/recipes-core/systemd/systemd_213.bb
index 28cc4cb0d9..5de7cdc3b2 100644
--- a/meta/recipes-core/systemd/systemd_213.bb
+++ b/meta/recipes-core/systemd/systemd_213.bb
@@ -244,7 +244,7 @@ FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ $
RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV})"
-RRECOMMENDS_${PN} += "systemd-serialgetty systemd-compat-units \
+RRECOMMENDS_${PN} += "systemd-serialgetty systemd-compat-units udev-hwdb\
util-linux-agetty \
util-linux-fsck e2fsprogs-e2fsck \
kernel-module-autofs4 kernel-module-unix kernel-module-ipv6 \
@@ -255,7 +255,8 @@ PACKAGES =+ "udev-dbg udev udev-hwdb"
FILES_udev-dbg += "/lib/udev/.debug"
RPROVIDES_udev = "hotplug"
-RRECOMMENDS_udev += "udev-hwdb"
+
+RDEPENDS_udev-hwdb += "udev"
FILES_udev += "${base_sbindir}/udevd \
${rootlibexecdir}/systemd/systemd-udevd \