aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-10-16 17:07:55 +0800
committerChen Qi <Qi.Chen@windriver.com>2014-10-16 17:17:49 +0800
commit222ef849d28064ba0786fb5bf929554d6389c9cc (patch)
tree4461d72f8d6c798d8311a6fd07bdc9f7d81f5322
parentfcbd1b19383daf5e160a864df1418130da01be28 (diff)
downloadopenembedded-core-contrib-ChenQi/systemd-rdepends.tar.gz
systemd: fix runtime dependencyChenQi/systemd-rdepends
Previously, if we set 'NO_RECOMMENDATIONS' to "1", we cannot reach login in systemd systems. The problem is that several runtime dependencies are coded as 'recommended' in our project. This patch makes the following changes. 1. Add util-linux-agetty as a runtime dependency. Otherwise, getty services in systemd cannot start correctly. 2. Add systemd-serialgetty as a runtime dependency. Otherwise, serialgetty services cannot start correctly in systemd and we would have problem when using `runqemu qemux86 nographic'. 3. Remove 'systemd' from RDEPENDS of systemd-serialgetty. systemd-serialgetty justs ships systemd unit files, even if the init manager is 'sysvinit', these files do no harm. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb2
-rw-r--r--meta/recipes-core/systemd/systemd_216.bb5
2 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 1c34d5c747..f3acaada2d 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -36,8 +36,6 @@ do_install() {
fi
}
-RDEPENDS_${PN} = "systemd"
-
# This is a machine specific file
FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta/recipes-core/systemd/systemd_216.bb b/meta/recipes-core/systemd/systemd_216.bb
index ebf939574d..62fe5c7a21 100644
--- a/meta/recipes-core/systemd/systemd_216.bb
+++ b/meta/recipes-core/systemd/systemd_216.bb
@@ -267,11 +267,10 @@ FILES_${PN} = " ${base_bindir}/* \
FILES_${PN}-dbg += "${rootlibdir}/.debug ${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/"
FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd"
-RDEPENDS_${PN} += "kmod dbus util-linux-mount udev (= ${EXTENDPKGV})"
+RDEPENDS_${PN} += "kmod dbus systemd-serialgetty util-linux-mount util-linux-agetty udev (= ${EXTENDPKGV})"
RDEPENDS_${PN} += "volatile-binds"
-RRECOMMENDS_${PN} += "systemd-serialgetty systemd-compat-units udev-hwdb\
- util-linux-agetty \
+RRECOMMENDS_${PN} += "systemd-compat-units udev-hwdb\
util-linux-fsck e2fsprogs-e2fsck \
kernel-module-autofs4 kernel-module-unix kernel-module-ipv6 os-release \
"