aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-03-02 14:01:17 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-03-02 15:30:27 +0800
commitc8596d4e77f4604c819df7adc5851592f90bb5e9 (patch)
tree714e07fdbffe8d49c70b7e9d516ebd63d80faf4b
parentbc393da30306891617adbb5eda5f57c9209ff24f (diff)
downloadopenembedded-core-contrib-ChenQi/systemd-networkd.tar.gz
systemd: avoid parsing error when 'networkd' is enabled in PACKAGECONFIGChenQi/systemd-networkd
If 'networkd' is enabled in PACKAGECONFIG, the do_install variable cannot be correctly expanded. Error message is like below. Failure expanding variable do_install: ShellSyntaxError: LexToken(Fi,'fi',0,0) followed by: LexToken(NEWLINE,'\n',0,0) This patch fixes the above problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index f245239c18..d785255e10 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -169,7 +169,7 @@ do_install() {
# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
# for existence else it fails
if [ -s ${D}${libdir}/tmpfiles.d/systemd.conf ]; then
- ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
+ ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
fi
}