aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-04-07 17:05:50 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-04-07 17:21:33 +0800
commitca141106b28e9f213b0965de589507300ccbbca3 (patch)
treeaef833815c2af40bbc2e0758f1b15d2da968a442
parent5ebea1114d54120d5ff5d8a6cd148110d0fda23f (diff)
downloadopenembedded-core-contrib-ChenQi/grub2-largefile.tar.gz
grub2: fix do_configure failure when largefile is not in DISTRO_FEATURESChenQi/grub2-largefile
When 'largefile' is not in DISTRO_FEATURES, '--disable-largefile' is passed to the configure options. However, the configure script checks the size of off_t regardless of this option. This raises the following error. configure: error: Large file support is required This patch fixes the above problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-bsp/grub/files/0001-configure.ac-support-disabling-largefile.patch44
-rw-r--r--meta/recipes-bsp/grub/grub2.inc1
2 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/files/0001-configure.ac-support-disabling-largefile.patch b/meta/recipes-bsp/grub/files/0001-configure.ac-support-disabling-largefile.patch
new file mode 100644
index 0000000000..e22dc00f6f
--- /dev/null
+++ b/meta/recipes-bsp/grub/files/0001-configure.ac-support-disabling-largefile.patch
@@ -0,0 +1,44 @@
+Upstream-Status: Pending
+
+Subject: configure.ac: support disabling largefile
+
+Do not check off_t size when largefile is disabled.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ configure.ac | 19 ++++++++++++-------
+ 1 file changed, 12 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index df20991..14ff7ac 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -306,13 +306,18 @@ if test x$grub_cv_apple_cc = xyes ; then
+ HOST_LDFLAGS="$HOST_LDFLAGS -Wl,-allow_stack_execute"
+ fi
+
+-case "$host_os" in
+- cygwin | windows* | mingw32* | aros*)
+- ;;
+- *)
+- AC_CHECK_SIZEOF(off_t)
+- test x"$ac_cv_sizeof_off_t" = x8 || AC_MSG_ERROR([Large file support is required]);;
+-esac
++AC_ARG_ENABLE([largefile],
++ [AS_HELP_STRING([--enable-largefile],
++ [Enable large file support (default=guessed)])])
++if test x"$enable_largefile" = xyes ; then
++ case "$host_os" in
++ cygwin | windows* | mingw32* | aros*)
++ ;;
++ *)
++ AC_CHECK_SIZEOF(off_t)
++ test x"$ac_cv_sizeof_off_t" = x8 || AC_MSG_ERROR([Large file support is required]);;
++ esac
++fi
+
+ if test x$USE_NLS = xno; then
+ HOST_CFLAGS="$HOST_CFLAGS -fno-builtin-gettext"
+--
+1.9.1
+
diff --git a/meta/recipes-bsp/grub/grub2.inc b/meta/recipes-bsp/grub/grub2.inc
index 146dde60c0..6cd8d36d44 100644
--- a/meta/recipes-bsp/grub/grub2.inc
+++ b/meta/recipes-bsp/grub/grub2.inc
@@ -30,6 +30,7 @@ SRC_URI = "ftp://ftp.gnu.org/gnu/grub/grub-${PV}.tar.gz \
file://0001-Fix-CVE-2015-8370-Grub2-user-pass-vulnerability.patch \
file://0001-Remove-direct-_llseek-code-and-require-long-filesyst.patch \
file://fix-texinfo.patch \
+ file://0001-configure.ac-support-disabling-largefile.patch \
"
DEPENDS = "flex-native bison-native"