aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-10-19 10:51:41 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-10-19 11:12:37 +0800
commit09b86abb79d3b5566d12ee2b56d56eacb98b3f1f (patch)
tree4ce386bd238d959a091f1108cb66600e7c04104b
parent9a2f02ae5505b4c9cbfa0ba502cbcd6db2c0b803 (diff)
downloadopenembedded-core-contrib-ChenQi/etc-pam.tar.gz
sudo: fix file permission for /etc/pam.d/sudoChenQi/etc-pam
The file permission should be 0644 instead of 0664. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-extended/sudo/sudo_1.8.14p3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
index 6b3cd6dbf5..b93112fa3f 100644
--- a/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
+++ b/meta/recipes-extended/sudo/sudo_1.8.14p3.bb
@@ -22,7 +22,7 @@ EXTRA_OECONF += " \
do_install_append () {
if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then
- install -D -m 664 ${WORKDIR}/sudo.pam ${D}/${sysconfdir}/pam.d/sudo
+ install -D -m 644 ${WORKDIR}/sudo.pam ${D}/${sysconfdir}/pam.d/sudo
fi
chmod 4111 ${D}${bindir}/sudo