aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-02 05:16:53 -0500
committerChen Qi <Qi.Chen@windriver.com>2014-12-02 18:24:39 +0800
commitd25f21723889062609cbb41db864b69e3e784f6e (patch)
tree4a1e5abc6984f79c6116cefce825151d0ee863ee
parent68ddb28a68ceb59cd1ed322c16143827ce1ac712 (diff)
downloadopenembedded-core-contrib-ChenQi/bootchart2.tar.gz
bootchart2: fix to find collector correctly in case of multilibChenQi/bootchart2
This patch fixes the following error of being not able to find the bootchart-collector program when using bootchart2 in multilib system. In order for bootchartd to correctly find the collector program, we need to set several vars while compiling. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_git.bb b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
index 04fb901b68..5fc7211f79 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_git.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_git.bb
@@ -120,6 +120,12 @@ do_compile_append_class-native () {
chmod +x ${S}/pybootchartgui
}
+do_compile_prepend () {
+ export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
+ export BINDIR="${bindir}"
+ export LIBDIR="${base_libdir}"
+}
+
do_install () {
install -d ${D}${sysconfdir} # needed for -native
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"