aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:36 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commitbc5d83d4b8c11257287c4fb0f8eaf915355d8e6f (patch)
tree155742ccf05d7e37fae2a5d0f5694b2ae459c3f2
parentc23cfe326c264d352c82a1b3aa6f95bfe5cf6c53 (diff)
downloadmeta-python2-bc5d83d4b8c11257287c4fb0f8eaf915355d8e6f.tar.gz
Remove deprecated python3-textutils from the RDEPENDS
The python3-textutils package was merged into core as part of the json manifest migration (From meta-openembedded commit: 49b6db7e66bbff7ec0c1ddbd746c656004527db5) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-asn1crypto.inc1
-rw-r--r--recipes-devtools/python/python-asn1crypto_0.24.0.bb4
-rw-r--r--recipes-devtools/python/python-jinja2.inc2
-rw-r--r--recipes-devtools/python/python-jinja2_2.10.bb6
-rw-r--r--recipes-devtools/python/python-jsonschema.inc1
-rw-r--r--recipes-devtools/python/python-jsonschema_2.6.0.bb1
-rw-r--r--recipes-devtools/python/python-netaddr.inc1
-rw-r--r--recipes-devtools/python/python-netaddr_0.7.19.bb4
8 files changed, 15 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-asn1crypto.inc b/recipes-devtools/python/python-asn1crypto.inc
index 0d3ee41..2777c21 100644
--- a/recipes-devtools/python/python-asn1crypto.inc
+++ b/recipes-devtools/python/python-asn1crypto.inc
@@ -18,7 +18,6 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-datetime \
${PYTHON_PN}-io \
${PYTHON_PN}-netclient \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-subprocess \
"
diff --git a/recipes-devtools/python/python-asn1crypto_0.24.0.bb b/recipes-devtools/python/python-asn1crypto_0.24.0.bb
index 6af60c2..1218519 100644
--- a/recipes-devtools/python/python-asn1crypto_0.24.0.bb
+++ b/recipes-devtools/python/python-asn1crypto_0.24.0.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-asn1crypto.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-textutils \
+"
diff --git a/recipes-devtools/python/python-jinja2.inc b/recipes-devtools/python/python-jinja2.inc
index 510765b..0c0bf0d 100644
--- a/recipes-devtools/python/python-jinja2.inc
+++ b/recipes-devtools/python/python-jinja2.inc
@@ -8,7 +8,7 @@ SRC_URI[md5sum] = "61ef1117f945486472850819b8d1eb3d"
SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea01914a4"
RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
- ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-math ${PYTHON_PN}-netclient \
${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
diff --git a/recipes-devtools/python/python-jinja2_2.10.bb b/recipes-devtools/python/python-jinja2_2.10.bb
index 0607521..5233cf4 100644
--- a/recipes-devtools/python/python-jinja2_2.10.bb
+++ b/recipes-devtools/python/python-jinja2_2.10.bb
@@ -1,4 +1,8 @@
inherit pypi setuptools
require python-jinja2.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-lang ${PYTHON_PN}-re"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-lang \
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-textutils \
+"
diff --git a/recipes-devtools/python/python-jsonschema.inc b/recipes-devtools/python/python-jsonschema.inc
index 748ef6e..8413692 100644
--- a/recipes-devtools/python/python-jsonschema.inc
+++ b/recipes-devtools/python/python-jsonschema.inc
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-shell \
${PYTHON_PN}-strict-rfc3339 \
${PYTHON_PN}-subprocess \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-unittest \
"
diff --git a/recipes-devtools/python/python-jsonschema_2.6.0.bb b/recipes-devtools/python/python-jsonschema_2.6.0.bb
index c118f2d..7407616 100644
--- a/recipes-devtools/python/python-jsonschema_2.6.0.bb
+++ b/recipes-devtools/python/python-jsonschema_2.6.0.bb
@@ -7,4 +7,5 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-functools32 \
${PYTHON_PN}-lang \
${PYTHON_PN}-re \
+ ${PYTHON_PN}-textutils \
"
diff --git a/recipes-devtools/python/python-netaddr.inc b/recipes-devtools/python/python-netaddr.inc
index 486bfc6..5b6d4df 100644
--- a/recipes-devtools/python/python-netaddr.inc
+++ b/recipes-devtools/python/python-netaddr.inc
@@ -9,6 +9,5 @@ inherit pypi
RDEPENDS_${PN} += " \
${PYTHON_PN}-pprint \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-xml \
"
diff --git a/recipes-devtools/python/python-netaddr_0.7.19.bb b/recipes-devtools/python/python-netaddr_0.7.19.bb
index 5e089a9..ca5a79a 100644
--- a/recipes-devtools/python/python-netaddr_0.7.19.bb
+++ b/recipes-devtools/python/python-netaddr_0.7.19.bb
@@ -1,2 +1,6 @@
require python-netaddr.inc
inherit setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-textutils \
+"