aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-08-27 12:28:03 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commit5425823dafaf37d3a385e64d84d6aa5a1c53dd21 (patch)
treed6cfd159f02ca0be7a370f3c24d7dee9a07f63a2
parente7b9a7faa3a1b50847089d282a8d37cd04b45699 (diff)
downloadmeta-python2-5425823dafaf37d3a385e64d84d6aa5a1c53dd21.tar.gz
python-subprocess32: add recipe for v3.2.7
A backport of the subprocess module from Python 3.2 for use on 2.x (From meta-openembedded commit: e975dd7786bdb55c6db34fcaf685df49fc4ba080) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-subprocess32_3.2.7.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-subprocess32_3.2.7.bb b/recipes-devtools/python/python-subprocess32_3.2.7.bb
new file mode 100644
index 0000000..f437069
--- /dev/null
+++ b/recipes-devtools/python/python-subprocess32_3.2.7.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A backport of the subprocess module from Python 3.2 for use on 2.x"
+DESCRIPTION = "This is a backport of the subprocess standard library module \
+from Python 3.2 - 3.5 for use on Python 2. It includes bugfixes and some new \
+features. On POSIX systems it is guaranteed to be reliable when used in \
+threaded applications. It includes timeout support from Python 3.3 and the \
+run() API from 3.5 but otherwise matches 3.2's API."
+LICENSE = "Python-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d3e62baa8fb96b11a59d3f2cd335d5c0"
+
+SRC_URI[md5sum] = "824c801e479d3e916879aae3e9c15e16"
+SRC_URI[sha256sum] = "1e450a4a4c53bf197ad6402c564b9f7a53539385918ef8f12bdf430a61036590"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native nativesdk"