aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-07-19 17:33:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:53 +0200
commit42821d2e1bba462ea4a35d0fabbe8c04aa70adb3 (patch)
treecb72a61438ce54edbbc01980d569b2d11199adfa
parentf10d00bcfd279ff2d5338ae28b9c0021c4902df0 (diff)
downloadmeta-python2-42821d2e1bba462ea4a35d0fabbe8c04aa70adb3.tar.gz
python-requests, python3-requests: update to 2.28.1
The copyright year changed in the license file. (From meta-openembedded commit: c00f87f211b7cbf196d314e356ce982073723a87) Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-requests.inc10
-rw-r--r--recipes-devtools/python/python-requests_2.18.1.bb (renamed from recipes-devtools/python/python-requests_2.13.0.bb)2
2 files changed, 8 insertions, 4 deletions
diff --git a/recipes-devtools/python/python-requests.inc b/recipes-devtools/python/python-requests.inc
index b66f66e..81819bf 100644
--- a/recipes-devtools/python/python-requests.inc
+++ b/recipes-devtools/python/python-requests.inc
@@ -1,10 +1,12 @@
DESCRIPTION = "Python HTTP for Humans."
HOMEPAGE = "http://python-requests.org"
LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d9bb3515869c0f426cb8441c899ae7f5"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=979d6a23b143e13ea0e5e3aa81248820"
-SRC_URI[md5sum] = "921ec6b48f2ddafc8bb6160957baf444"
-SRC_URI[sha256sum] = "5722cd09762faa01276230270ff16af7acf7c5c45d623868d9ba116f15791ce8"
+SRC_URI[md5sum] = "40f723ed01dddeaf990d0609d073f021"
+SRC_URI[sha256sum] = "c6f3bdf4a4323ac7b45d01e04a6f6c20e32a052cd04de81e05103abc049ad9b9"
+
+inherit pypi
RDEPENDS_${PN} += " \
${PYTHON_PN}-email \
@@ -15,6 +17,8 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-pyopenssl \
${PYTHON_PN}-pysocks \
${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna \
"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/python/python-requests_2.13.0.bb b/recipes-devtools/python/python-requests_2.18.1.bb
index 627bc95..0d7a29f 100644
--- a/recipes-devtools/python/python-requests_2.13.0.bb
+++ b/recipes-devtools/python/python-requests_2.18.1.bb
@@ -1,4 +1,4 @@
-inherit pypi setuptools
+inherit setuptools
require python-requests.inc
RDEPENDS_${PN} += "${PYTHON_PN}-zlib"