aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/aliens
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/aliens
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/aliens')
-rw-r--r--recipes-qtopia/aliens/aliens_1.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qtopia/aliens/aliens_1.0.0.bb b/recipes-qtopia/aliens/aliens_1.0.0.bb
new file mode 100644
index 0000000..ca6e1bb
--- /dev/null
+++ b/recipes-qtopia/aliens/aliens_1.0.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Classic Arcade Shooter for Qt/Embedded based palmtop environments"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "aliens.sdl"
+APPTYPE = "binary"
+PR = "r4"
+
+SRC_URI = "ftp://ftp.billsgames.com/unix/agenda/aliens/src/aliens_V${PV}.tar.gz"
+S = "${WORKDIR}/aliens_V${PV}"
+
+inherit opie
+
+do_compile_prepend() {
+ cd images && make && cd ..
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics
+ install -m 0644 aliens.png ${D}${palmtopdir}/pics/aliens.png
+}
+
+SRC_URI[md5sum] = "9d7cde75aecf4b85478c0e47343d4293"
+SRC_URI[sha256sum] = "0aa0084a74f912f4002f1c40a815ce62ac13331ec84787a954d8bea06e1c96c5"