aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/libqpe
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-20 01:33:23 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-20 19:23:31 +0100
commit9eabed4401eaffa52caa6fd601d7918c80afdb46 (patch)
treedf9e7b736d12ed895965be6a3869b56aa54ab762 /recipes-opie/libqpe
parent6a43d20ed50f1cde3c6bf4445d282c83cba30bb5 (diff)
downloadmeta-opie-9eabed4401eaffa52caa6fd601d7918c80afdb46.tar.gz
Tidy up definitions of OPIE_GIT_PV / OPIE_SRCREV
If you want to build Opie, then you should be using one of the .inc files from meta-opie/conf/distro/include to set everything up correctly. Thus, remove all additional definitions of these variables and add a warning to be shown if one of the inc files has not been used. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/libqpe')
-rw-r--r--recipes-opie/libqpe/libqpe-opie.inc7
-rw-r--r--recipes-opie/libqpe/libqpe-opie_git.bb6
2 files changed, 7 insertions, 6 deletions
diff --git a/recipes-opie/libqpe/libqpe-opie.inc b/recipes-opie/libqpe/libqpe-opie.inc
index cc8922f..7ddc40c 100644
--- a/recipes-opie/libqpe/libqpe-opie.inc
+++ b/recipes-opie/libqpe/libqpe-opie.inc
@@ -12,6 +12,13 @@ S = "${WORKDIR}/library"
inherit palmtop
+python __anonymous() {
+ # This doesn't need to be in this recipe specifically, but it's as good
+ # a place as any since it has to be parsed if Opie is going to be built
+ if not bb.data.getVar("OPIE_VERSION", d, True):
+ bb.warn("OPIE_VERSION has not been set; if you are going to build Opie, you need to 'require' an appropriate .inc file from meta-opie/conf/distro/include")
+}
+
OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
QMAKE_PROFILES = "library.pro"
EXTRA_QMAKEVARS_PRE += "CONFIG+=LIBQPE_WITHROHFEEDBACK"
diff --git a/recipes-opie/libqpe/libqpe-opie_git.bb b/recipes-opie/libqpe/libqpe-opie_git.bb
index 41a6e33..585c0ae 100644
--- a/recipes-opie/libqpe/libqpe-opie_git.bb
+++ b/recipes-opie/libqpe/libqpe-opie_git.bb
@@ -1,11 +1,5 @@
require ${PN}.inc
-# OPIE_GIT_PV is defined in opie.bbclass
-# but this recipe does not inherit opie
-# so any updates to OPIE_GIT_PV should happen
-# in both places.
-
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "${INC_PR}.0"