aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/farsight/libnice_0.0.13.bb')
-rw-r--r--meta-oe/recipes-support/farsight/libnice_0.0.13.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
index 3205aaf357..711b6bdbf0 100644
--- a/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
+++ b/meta-oe/recipes-support/farsight/libnice_0.0.13.bb
@@ -16,13 +16,17 @@ DEPENDS = "glib-2.0 gstreamer"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
-inherit autotools
+inherit autotools pkgconfig gtk-doc
FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la"
FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a"
FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+do_configure_prepend() {
+ mkdir ${S}/m4 || true
+}
+
do_compile_append() {
for i in $(find ${S} -name "*.pc") ; do
sed -i -e s:${STAGING_DIR_TARGET}::g \