aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb')
-rw-r--r--meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
index 986416ade2..4efc412a04 100644
--- a/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
+++ b/meta-networking/recipes-connectivity/vpnc/vpnc_0.5.3.bb
@@ -7,9 +7,16 @@ LICENSE = "GPL-2.0+"
LIC_FILES_CHKSUM = "file://COPYING;md5=173b74cb8ac640a9992c03f3bce22a33"
DEPENDS = "libgcrypt"
+inherit perlnative
+
CFLAGS_append = ' -DVERSION=\\"${PV}\\"'
LDFLAGS_append = " -lgcrypt -lgpg-error"
+do_configure_append () {
+ # Make sure we use our nativeperl wrapper
+ sed -i "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/*.pl
+}
+
do_install () {
sed -i s:m600:m\ 600:g Makefile
oe_runmake 'DESTDIR=${D}' 'PREFIX=/usr' install