aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
index d0176c53d4..9061c272fc 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_0.6.bb
@@ -42,13 +42,20 @@ SRC_URI = "https://github.com/kexecboot/kexecboot/archive/v${PV}.tar.gz"
SRC_URI[md5sum] = "46b7c1a6f20531be56445ebb8669a2b8"
SRC_URI[sha256sum] = "6b360b8aa59bc5d68a96705349a0dd416f8ed704e931fa0ac7849298258f0f15"
-inherit autotools-brokensep
+SRC_URI += "\
+ file://0001-kexecboot-fix-build-when-S-B.patch \
+ file://0002-kexecboot-fix-configure-warnings.patch \
+ file://0003-kexecboot-do-not-hardcode-MOUNTPOINT.patch \
+ file://0004-kexecboot.c-workaround-for-absolute-kernel-and-initr.patch \
+ "
+
+inherit autotools
EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250"
do_install () {
install -d ${D}${bindir}
- install -m 0755 kexecboot ${D}${bindir}/
+ install -m 0755 kexecboot ${D}${bindir}
install -d ${D}/proc
install -d ${D}/mnt
install -d ${D}/dev