aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-05-19 17:34:29 +0100
committerArmin Kuster <akuster808@gmail.com>2023-06-17 12:56:34 -0400
commit7075b40f410a97472eed73b745529283bc587f26 (patch)
treeb1d167c28823b0f6b7dc49926476880d307bc0c4
parent9fbb7a0b9243f009c86033e96248f2527f863ef5 (diff)
downloadmeta-openembedded-7075b40f410a97472eed73b745529283bc587f26.tar.gz
libblockdev: clean up DEPENDS
If you try to build libblockdev with an empty PACKAGECONFIG then the configure fails. Add autoconf-archive, glib-2.0, and udev; these were implicitly pulled in via other dependencies. Move kmod to DEPENDS as it's a hard requirement. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit f14663746bd519650c8654bbf91971a0a96c109e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.28.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.28.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.28.bb
index 44b4e7daf9..22ccbf144e 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.28.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.28.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
inherit autotools gobject-introspection pkgconfig
+DEPENDS = "autoconf-archive-native glib-2.0 kmod udev"
+
SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch;protocol=https \
"
SRCREV = "1412dc51c8f76bf8d9a6008228737db4a9a26d69"
@@ -24,12 +26,12 @@ PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
-PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
+PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd,libbytesize"
PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
-PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
+PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo,libbytesize"
PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"