aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandeep Gundlupet Raju 837 <sandeep.gundlupet-raju@amd.com>2023-06-20 09:39:17 -0600
committerArmin Kuster <akuster808@gmail.com>2023-06-23 08:02:41 -0400
commit54ec73da43f0e97b7a2a8b7c24f9b05b2072ce41 (patch)
tree16933b145b795a27604ed4ede1c8077d953668a8
parent5a01ab461c9bcabcbb2298236602373948f8f073 (diff)
downloadmeta-openembedded-54ec73da43f0e97b7a2a8b7c24f9b05b2072ce41.tar.gz
opencv: Revert fix runtime dependencies
This reverts commit 0abf5af3ffd3d13c009a8ffcd5a6f045c36be837 libopencv-ts package is not empty and libopencv_ts libraries are not all installed in the -dev package, these libraries are needed for sdk development listed in opencv4.pc file. Signed-off-by: Sandeep Gundlupet Raju <sandeep.gundlupet-raju@amd.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.7.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.7.0.bb b/meta-oe/recipes-support/opencv/opencv_4.7.0.bb
index 361b004308..bad6f1508f 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.7.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.7.0.bb
@@ -162,7 +162,7 @@ python populate_packages:prepend () {
metapkg = pn
d.setVar('ALLOW_EMPTY:' + metapkg, "1")
- blacklist = [ metapkg, "libopencv-ts" ]
+ blacklist = [ metapkg ]
metapkg_rdepends = [ ]
for pkg in packages[1:]:
if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale') and not pkg.endswith('-staticdev'):