aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-25 21:54:43 -0700
committerArmin Kuster <akuster808@gmail.com>2023-05-28 16:40:54 -0400
commit6609c87eaf528fcba344c2f2778714916931bf42 (patch)
tree1ccd7cf6945c289ae4d73a7c1b2b71d064757da5
parentffb2a0b552ba2fc8a76e8fb4b33b781b5fc5953e (diff)
downloadmeta-openembedded-6609c87eaf528fcba344c2f2778714916931bf42.tar.gz
vlan: Pass CFLAGS via CCFLAGS
CCFLAGS is used in Make rules which will ensure file remapping options are used when compiling Fixes WARNING: vlan-1.9-r0 do_package_qa: QA Issue: File /usr/sbin/.debug/vconfig.vlan in package vlan-dbg contains reference to TMPDIR [buildpaths] Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 26842ecc3b4811fd39a65c55af0711777f41fdbb) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/vlan/vlan_1.9.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
index 035d4946f1..b478692e39 100644
--- a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
+++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
@@ -28,7 +28,7 @@ do_configure:append () {
# ignore strip to avoid yocto errors in stripping
do_compile () {
- oe_runmake PLATFORM=ARM 'STRIP=echo' all
+ oe_runmake PLATFORM=ARM 'STRIP=echo' CCFLAGS="${CFLAGS}" all
}
do_install () {