aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-13 22:24:56 -0700
committerArmin Kuster <akuster808@gmail.com>2023-05-28 16:05:12 -0400
commit1e86587ed82ee62eb9737ebdc375d5f9140b753a (patch)
tree86881acd4069c2c341677fb4a7c8ef548716eb7f
parent6b59a43868630efeb59f82608c2708c6e35fa8b3 (diff)
downloadmeta-openembedded-1e86587ed82ee62eb9737ebdc375d5f9140b753a.tar.gz
lmdb: Pass CFLAGS to Makefile
This ensures that __FILE__ macros is expanded correctly without buildpaths Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 9af3510170137070cb269e6cf0399ac43ad8bece) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
index a76d388d70..35242bedb6 100644
--- a/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
+++ b/meta-oe/recipes-dbs/lmdb/lmdb_0.9.29.bb
@@ -21,11 +21,11 @@ inherit ptest
S = "${WORKDIR}/git/libraries/liblmdb"
do_compile() {
- oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}"
+ oe_runmake CC="${CC}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" XCFLAGS="${CFLAGS}"
}
do_install() {
- oe_runmake CC="${CC}" DESTDIR="${D}" prefix="${prefix}" libprefix="${libdir}" manprefix="${mandir}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" install
+ oe_runmake CC="${CC}" DESTDIR="${D}" prefix="${prefix}" libprefix="${libdir}" manprefix="${mandir}" SOEXT=".so.${PV}" LDFLAGS="${LDFLAGS}" XCFLAGS="${CFLAGS}" install
cd ${D}${libdir}
ln -s liblmdb.so.${PV} liblmdb.so
rm liblmdb.a