aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-22 17:40:26 +0800
committerArmin Kuster <akuster808@gmail.com>2023-12-04 09:47:03 -0500
commitc6eb66377af7f06105a938b8a947f3a17660c672 (patch)
tree4408918a145188a11bb9b68d741e5cf6a135d824
parentd1cb0ddb0142d43e4258818b0bf302ff3706ddb6 (diff)
downloadmeta-openembedded-c6eb66377af7f06105a938b8a947f3a17660c672.tar.gz
gattlib: Upgrade to latest tip of trunk
License-Update: Year changed [1] Remove build directory from include directives in generated sourcecode via gdbus-codegen Upgrade includes fix for CVE-2019-6498 [1] https://github.com/labapart/gattlib/commit/5c87eda925c597e72107b5026c6b8d490ce76d62 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tan Wen Yan <wen.yan.tan@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/gattlib/gattlib_git.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
index 1ba7dd4afc..aec41edf7a 100644
--- a/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
+++ b/meta-oe/recipes-connectivity/gattlib/gattlib_git.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Bluetooth library with attribute support"
SECTION = "libs/network"
LICENSE = "GPL-2.0-or-later | BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=6;md5=71fdd2be76b4e95fe28324a70d4981c5"
+LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=6;md5=a87ee154f005a6f035b8b34ac2191f3b"
DEPENDS = "bluez5 glib-2.0"
DEPENDS += "glib-2.0-native"
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/labapart/gattlib.git;branch=master;protocol=https \
"
SRCBRANCH = "master"
-SRCREV = "fa54ae42ccb3d8f911e00b02ed1e581537e47f79"
+SRCREV = "33a8a275928b186381bb0aea0f9778e330e57ec3"
S = "${WORKDIR}/git"
@@ -28,5 +28,12 @@ EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
inherit pkgconfig cmake
+do_compile:append() {
+ for f in org-bluez-gattdescriptor1.c org-bluez-battery1.c org-bluez-adaptater1.c \
+ org-bluez-device1.c org-bluez-gattservice1.c org-bluez-gattcharacteristic1.c; do
+ sed -i -e 's|${B}/dbus/||g' ${B}/dbus/$f
+ done
+}
+
FILES:${PN} = "${libdir}/*"
FILES:${PN}-dev = "${includedir}/* ${libdir}/pkgconfig"