aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2023-08-16 15:01:14 +0800
committerArmin Kuster <akuster808@gmail.com>2023-08-16 08:33:38 -0400
commitb0ba472191c2b7709ef04ae9c5a23bea040518f9 (patch)
treea324ede2107cc366ffd2d59db32a8cb26ec083cd
parentc89bb116aa3469ecff78203f51e8a5b70aeb3db8 (diff)
downloadmeta-openembedded-b0ba472191c2b7709ef04ae9c5a23bea040518f9.tar.gz
mcelog: Drop unneeded autotools-brokensep
Drop unneeded autotools-brokensep class inherit, this package has traditional makefile build. This change also fixes the below buildpaths issue altogether. WARNING: mcelog-191-r0 do_package_qa: QA Issue: File /usr/sbin/.debug/mcelog in package mcelog-dbg contains reference to TMPDIR [buildpaths] (cherry picked from commit 29e6c4928cfbfe3a00921b956938781d53563582) Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_191.bb11
1 files changed, 9 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_191.bb b/meta-oe/recipes-support/mcelog/mcelog_191.bb
index e713433469..3c1c451c02 100644
--- a/meta-oe/recipes-support/mcelog/mcelog_191.bb
+++ b/meta-oe/recipes-support/mcelog/mcelog_191.bb
@@ -18,11 +18,18 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
S = "${WORKDIR}/git"
-inherit autotools-brokensep ptest
+inherit ptest
COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
-do_install:append() {
+EXTRA_OEMAKE += "CFLAGS='${CFLAGS}'"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
install -d ${D}${sysconfdir}/cron.hourly
install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron