aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb b/meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb
new file mode 100644
index 0000000000..70c35844a1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-soupsieve_2.4.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "CSS selector library for python-beautifulsoup4"
+HOMEPAGE = "https://github.com/facelessuser/soupsieve"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=520586fa71ed2cbda50b4a8c89621e09"
+
+SRC_URI[sha256sum] = "89d12b2d5dfcd2c9e8c22326da9d9aa9cb3dfab0a83a024f05704076ee8d35ea"
+
+inherit pypi python_hatchling python_setuptools_build_meta ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-beautifulsoup4 \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-beautifulsoup4 \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"