aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-semver_2.10.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-semver_2.10.2.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
index b41ef5ddc7..71cb1acec3 100644
--- a/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
+++ b/meta-python/recipes-devtools/python/python3-semver_2.10.2.bb
@@ -7,6 +7,18 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665
SRC_URI[md5sum] = "3e11ae9782121e8ffe9f8a8b763a8cb5"
SRC_URI[sha256sum] = "c0a4a9d1e45557297a722ee9bac3de2ec2ea79016b6ffcaca609b0bc62cf4276"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_semver.py ${D}${PTEST_PATH}/
+}