aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb b/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
new file mode 100644
index 0000000000..1b4bb5a40e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
@@ -0,0 +1,19 @@
+SUMMARY = "RDFLib is a pure Python package for working with RDF"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37d489c0cefe52a17e1d5007e196464a"
+
+SRC_URI[sha256sum] = "72af591ff704f4caacea7ecc0c5a9056b8553e0489dd4f35a9bc52dbd41522e0"
+
+inherit pypi python_poetry_core
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-isodate \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"